Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Show preferred tool path shows all tools

#1
Hi!
I have a robot project with a tool changer. So there are many different tools attached to the robot. When I now create a curve follow project and press the "Show preferred tool path" button, the visualization shows me the tool path with all attached tools on the robot, although only one is visible and selected in the curve follow project options. This makes the feature useless.
How can I deactivate the preview of non-visible tools?
#2
If tools are flagged as cutters they won't be displayed with the preview. Cutter tools are automatically flagged as cutters when you import the tools from CAD/CAM plugins. Did you use a CAD/CAM plugin?

Can you share your RoboDK project? We can help you better.
#3
Hi Albert,

I can not attach the real project, but I created a simple project.
I loaded the tools from Fusion 360 with the RoboDK Plugin by clicking on "Load Model" and dropping it afterwards on the robot.
How can I set the cutter flag? I have not found an option by searching the API documentation for "cutter" and looking through the options in Fusion and RoboDK.

Edit: I added a screenshot.

.rdk   show_preferred_tool_path_project.rdk (Size: 1.22 MB / Downloads: 168)


Attached Files Thumbnail(s)
   
#4
I updated your project with a script that allows you to mark any tool as a cutter. Cutters won't be displayed in the preview.

See script called Set Tool as Cutter in the RDK project attached.

In short, this script sets the cutter using this command:
Code:
tool.setParam("Cutter", 1)


Attached Files
.rdk   show_preferred_tool_path_project-v2.rdk (Size: 1.22 MB / Downloads: 187)
#5
This worked great! Thank you very much!
  




Users browsing this thread:
1 Guest(s)