Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SolidWorks RoboDK Plug-in LoadPart Not Rendering
#1
Hi,

I have upgraded RoboDK to the newest version, and I am using Solidworks 2017. I created a simple model in Solidworks just to try out the Solidworks RoboDK plug-in. However, the part can't be load into RoboDK.
[Image: Screen-Shot.png]
Please advise.
Thanks,
Joshua


Attached Files
.zip   SW_file.zip (Size: 67.86 KB / Downloads: 81)
#2
Hi liushuya7, 

Can you send me the RoboDK file please? 

I tried a few things, but I was unsuccessful at reproducing your problem... It simply worked every time with every single setting that I tried. 

The only thing that differs for the moment is the fact that you use the 2017 version and I'm using the 2018 (we tested that in the past and it was not an issue) and the fact that you have a student license of SolidWorks and I have a Pro one (we didn't test that). (Having a student license of RoboDK is not an issue either.) 

On your side, you can try the following. In the RDK plugin for SW, there is a setting button.
Try changing the export format for .stl (in fact, try all three options). 

   

Also, you can try to make sure that you use the default settings of RDK (updating RDK don't reset the custom settings).

   

Jeremy
#3
Hi Jeremy,

Thanks for the helpful instructions!
By following your instructions, it solved my problem.
When I try changing the export format for .stl or any other format in the drop-down list. It renders successfully into RoboDK.
Afterwards, even when I go back to default, it also renders well. The only time it didn't work was when the first time after loading RoboDK plug-in into Solidworks and I left the export format as default. Now everything works fine. Thanks!

Joshua
#4
Always happy to help!

Jeremy
  




Users browsing this thread:
1 Guest(s)