Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Synchronize External Axis
#1
Hello all,

I am trying to use a RoboDK Machining/Curve Project for metal Additive Manufacturing with synchronized external axis, since those are the only projects where I can upload to RoboDK a file with the structure X,Y,Z, I, J, K. However, I cannot use the smart axis controller for the example provided. The objective of the cell is to produce a circular rim upon a cylindric main body with two robots. The joints of the 6-Axis robot should move as little as possible and the first joint of the turntable should be static, as you can see in the picture below. The rim is then produced by rotating the second joint of the turntable. 
I tried different configurations for the “Joint Reference” and with different values on the priorities text boxes. Also, I tested the “Prioritize External Axis”, but it was unsuccessful. Both pictures and projects attached. 

Could you please help me with that?
Thank you.

Best regards,
Bernardo Freire


Attached Files Thumbnail(s)
       

.rdk   rdk_project.rdk (Size: 5.08 MB / Downloads: 71)
#2
Hi Bernardo,

Using the Smart Optimization option may complicate things too much in this case if you only want to move the second axis of your turntable (8th axis of your setup).

I recommend you to follow these steps:
  1. Double click Rim_Test Settings to open the robot machining setup
  2. In Turntable optimization, check Auto Compensation
  3. Select Teach keeping the robot in the same location you have it (or your preferred orientation): the Path to tool offset, shift turn and position of external axes will be calculated automatically.
  4. If you have a turntable with a limited number of turns (such as +/- 2 turns in your case): I recommend you to manually enter 0 deg for the 8th axis to prevent reaching a joint limit of the turntable.
See image attached with the important settings and the project solved.
   

Albert


Attached Files
.rdk   Project-Turntable.rdk (Size: 7.13 MB / Downloads: 82)
#3
Hello Albert, 

I just tried your suggestion but unfortunately, it didn't work, please check what I am getting (project attached). If I check the "Show relative Tool Path" I can see the relative moves and not all are correct (image attached). Finally, I tested your suggestion plus the addition of the "Preferred joints for the start point", but once again the desired orientation was not achieved.   
Regarding your project I also check it. It is working but not with the orientations I desire (-90deg on the 7th axis and tool coaxial, or the closest possible). Do you think that is feasible?
Nowadays, I am running RoboDK v4.2.3. I don't know this has some influence.

Best regards, 
Bernardo Freire


Attached Files Thumbnail(s)
   

.rdk   Multi-Axis Example AM_2.rdk (Size: 5.08 MB / Downloads: 75)
#4
Hi Bernardo, 

Make sure that you are using the latest version of RDK. "Main menu"->"Help"->"Check for updates".

I just downloaded your station, from where it was, I simply pressed the "Teach" button and everything was working fine after the update. 

   

Jeremy
#5
Hello, 

I just updated the software for the 4.2 version and tested the project. It works better than before. However I still cannot achieve the desired orientations. I cannot keep the tool with a 0 deg Z axis rotation. 

Best regards, 
Bernardo Freire


Attached Files Thumbnail(s)
       
  




Users browsing this thread:
1 Guest(s)