Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The Circle Position Is Too Close To The Start or End Position of The Circle
#1
Hi all,

Just about to rip the last of my hair out with this one.

As above - ABB Error 50063 - The Circle Position Is Too Close To The Start or End Position of The Circle 

It comes up about 3/4 way through machining. I've included the RDK and would be very very grateful if someone would take a look? I've also attached a screenshot of the error.

As a side - while having a look at the station, could anyone explain why RDK seems to be ignoring my smoothing command? No matter what I do it posts z1 as my zone data.

Any help, massively appreciated!


All the best,
James


Attached Files Thumbnail(s)
   

.rdk   ROBOT STATION 2020.rdk (Size: 3.72 MB / Downloads: 58)
#2
Hi Jyardley, 

I'll try to help you the best I can as I don't want us to be the reason for your hair loss. Hehe.

First, I took a look at your station, and for a weird reason, you are using one of the legacy post-processor. 
The "white" post-processors are only there for backward compatibility. I would recommend you to use the "black" ones. See screen capture below (select either IRC5 or S4C depending on the controller you are using):

   

This should solve the "smoothing" problem you are experiencing. 
If this doesn't solve the MoveC problem we have a few other solutions. 
It would be nice to know at which line of the ABB code the program crashes. That would help us narrow down the error. 

The first, and ideal, solution would be to make sure that your CAM program doesn't generate MoveC smaller than the minimum value your robot controller can handle. There's generally a "tolerance" setting that you can manage in the CAM software for the linear movement, I imagine that the same thing is possible for MoveC. 

Small note here, I see that you generated a .NC file from your CAM software, did you do it manually or using one of our plugins? If the answer is "manually" try to see if your CAM software includes a post-processor generating .apt files. We usually have better results with that file format. (This should not affect the present situation, it's just a tip for the future.)

The second solution would be to request your CAM software not to generate MoveC, but rather generate a bunch of small MoveLs. If the linear movements are small enough, you shouldn't see the difference in the real program executed on the robot. Better than that, the older robots/controllers are not always super good at maintaining the real trajectory on MoveC, therefore transforming the MoveC in a bunch of small MoveL can possibly improve the actual accuracy of the path. 

The third solution would be to modify the "Minimum arc size" in the RoboDK options. 
"Main menu" -> "Tools" -> "Options" (can also be reached with "shift + o") -> "Programs"

   

This option will only affect the post-processed program, you shouldn't see any difference in the RoboDK station. 

Let me know if it helps. 
Also, make sure you are using the latest version of RoboDK: 
"Main menu" -> "Help" -> "Check for updates". 

Jeremy
#3
Hi Jeremy,

Thanks so much for the prompt reply. I must admit I knew about the post not being 100% correct but everytime I try to use the later 'black' S4C post the following error is thrown - 

Failed to generate program "main" using the Post Processor "ABB_RAPID_S4C"
Post processor path:/Applications/RoboDK.app/Contents/Posts/ABB_RAPID_S4C.py
2020-04-22 13:48:31.880 Python[24423:1115105] WARNING: found it necessary to prepare implicitly; please prepare panels using NSSavePanel rather than NSApplication or NSWindow.

Process output:
Total instructions: 75
Done instruction: 10
Done instruction: 20
Done instruction: 30
Done instruction: 40
Done instruction: 50
Done instruction: 60
Done instruction: 70

Python Post Processor process exit code: 0


Which is why I have always used the legacy post. Maybe you could suggest why the above error is thrown?

I'm going to try what you have suggested on the arc issue and will report back. That particular section of code is based on a spline so suspect there are some tiny arcs in there. 

All help as always very much appreciated!

All the best,

James 

PS - My hair is saying thanks too.
#4
Hi James,

Can you go "Tools"->"Options"->"Other" and click the first "Select" button you see at the top of the window. If you have more then one Python version installed on your computer, select the 3.7 version, if not it will be selected automatically.
Let me know if it works as it does on my end right now.
This seems to be a "Python" problem rather than a "RoboDK" problem as the "white" post-processor use C language. (Don't get me wrong, I'm not saying it's a "Python" problem as "it's not our problem", just as "we should look in that direction first".)

Jeremy
#5
Maybe a ''Mac' issue?

   
#6
I'll forward that to our dev team. We'll see what they think about that. I don't have access to a Mac station.
In the meantime, can you try with the normal "IRC5" post-processor? Do you face the same issue?

Jeremy
#7
Hi James,

Can you enter python3 instead of python in:
Tools-Options-Other-Python run path

Let me know if you still have issues.

Albert
#8
(04-22-2020, 01:49 PM)Jeremy Wrote: I'll forward that to our dev team. We'll see what they think about that. I don't have access to a Mac station.
In the meantime, can you try with the normal "IRC5" post-processor? Do you face the same issue?

Jeremy

All later posts gove the same error yes.

(04-22-2020, 02:03 PM)Albert Wrote: Hi James,

Can you enter python3 instead of python in:
Tools-Options-Other-Python run path

Let me know if you still have issues.

Albert

Hi Albert,

Hmmm - nope still not working.
#9
Hi James,

Can you try installing Python separately from the official website?
Then, python3 should work.

I believe the issue you originally see is just a warning message caused by the Python version included on Mac.
The program is still generated. Correct?

If you still see issues, can you provide more information about the error message?

Albert
  




Users browsing this thread:
2 Guest(s)