Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The robot do not run as the preview
#1
Hi All,
I am still working on a laser cutting project. Today I created a new curve, and build a follow curve project.
In the preview(the green path),I can see the tool and the robot are following the path. But after excuting the simulation, the robot go so far from the path I created. I add the project file here, Can you help to check what is wrong on my station?
   
Thanks.


Attached Files
.rdk   debug.rdk (Size: 8.2 MB / Downloads: 31)
#2
Hi KP,

Do you mean when you execute the simulation in RoboDK or on the real robot?
Because everything seems fine when I run the simulation on my end (Except for a small collision between the robot arm and the turn table).

Jeremy
#3
(07-06-2020, 04:29 PM)Jeremy Wrote: Hi KP,

Do you mean when you execute the simulation in RoboDK or on the real robot?
Because everything seems fine when I run the simulation on my end (Except for a small collision between the robot arm and the turn table).

Jeremy

Hi Jeremy,
Thanks for your information,Let me explain my error.
1-I added a part, and create a curve, then created a curve follow project.
2-I found the jig is too far to reach, so I have to move the jig basement more closer ;
3-I re-select the curve and created the project again;
In the simulation, I found the robot still run follow the OLD path. (You can see the picture, the robot stayed far away from the green path.).In fact the robot should move to the green path.
Every time, if I created a path, and then deleted it. And made some modify on the jig/part frame, the software can create/update the correct path again. But the robot can not follow the new path.
#4
Hi KP, 

Oh, I see. I'm pretty sure I know what's going on. 
When you move a curve like that you need to modify the origin of the curve, not just its position. 
Super simple: Double-click the curve to open the Object Details window. Select More Options and enter the movement under Move Geometry. Once you know you have the right position, you can Apply the changes.

   

Hope it helps. 
Jeremy
  




Users browsing this thread:
1 Guest(s)