Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

UR CB2 connection to RoboDK


We have a UR10 CB2 robot with PolyScope version 1.8.16941.

We would like to connect to it trough RoboDK, but it stuck on Waiting... status.

We have tried in many ways, we have gone through every forum thread related to this issue, but we have not been able to solve this problem.

Is it impossible to connect UR CB2 robots with RoboDK?

Any help would be really appreciated!

Yes, you can connect UR CB2 controllers with RoboDK. Make sure to properly change the version to 1 (CONTROLLER_VERSION=1) in the apiur.exe.ini file.

More information here:
I have changed CONTROLLER_VERSION=1, restarted computer and tried once again
but RoboDK still stuck on Waiting...

Here's log:

Starting robot driver: C:/RoboDK/api/robot/apiur.exe
RoboDK driver for UR v3.9.0
Loading settings: C:/Users/Robo DK/AppData/Roaming/RoboDK-Drivers/apiur.exe.ini
MoveJ with Joints: Yes
MoveL with Joints: Yes
MoveL as: movel(...)
Controller Version: 1
Communication Timeout (ms): 1000
Sending command...
Available local IP addresses (IPv4):
Server established:
Warning: Using older controller compatibility (IO not supported)
Connected to Sending program :/progrobodk_basic.script...
Updating computer IP on program:
Updating computer port on program: 30000
Program sent.


Any other ideas?
Can you try running RoboDK as an Administrator and turning off you Windows Firewall?
I tried running RoboDK as administrator and also I disabled the Windows firewall, but that didn't help.
Can you check the log window on the UR teach pendant?

Let us know if you see any errors or warnings. You should expect to see some Warning messages regarding a socket timeout (this is normal).
I can't see any information or errors related to the connection as on picture below.


Users browsing this thread:
1 Guest(s)