Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Ubuntu 16.04 Segmentation Fault After Installation

Hello everyone,

SUMMARY: having Segmentation Fault while running ./RoboDK in bin folder.

I have heard of RoboDK simulation on some forum, then decided to try it myself. I am using Ubuntu 16.04 as system.

First I want to mention that I have followed the installation readme file first. Yet it did not work out as expected.

After extracting the files, I ran he install bash.

After that running the RoboDK file in bin folder has given me some errors about not being able to find some library so files related to Qt. Even though those libraries were installed in the pc. Then I updated my bashrc file to include the missing libraries in my LD_LIBRARY_PATH.

I changed the LD_LIBRARY_PATH to include path to those files. After sourcing it, there were no more missing library error.

After running the RoboDK file in bin folder, I got the following output in my terminal.

Starting  "RoboDK v3.5.0"  ...
Segmentation fault (core dumped)

Then examining sh files in the main folder, ie. I saw these paths are exported there as
export LD_LIBRARY_PATH="$(pwd)/lib"

export QT_PLUGIN_PATH="$(pwd)/plugins/"
export QT_QPA_PLATFORM_PLUGIN_PATH="$(pwd)/plugins"

I changed them into the following ones with a small hope that it works better.
export LD_LIBRARY_PATH="$(pwd)/lib":"/home/mert/Qt/5.11/gcc_64/lib/":"/home/mert/Qt/5.11.1/gcc_64/lib/"
export QT_PLUGIN_PATH="$(pwd)/plugins/":"/home/mert/Qt/5.11/gcc_64/lib/":"/home/mert/Qt/5.11.1/gcc_64/lib/"
export QT_QPA_PLATFORM_PLUGIN_PATH="$(pwd)/plugins":"/home/mert/Qt/5.11/gcc_64/lib/":"/home/mert/Qt/5.11.1/gcc_64/lib/"

However I still get the same error.

Starting  "RoboDK v3.5.0"  ...
Segmentation fault (core dumped)

Any idea what might be wrong ?
Hi Mert,

I recommend you to try installing latest version of RoboDK for Ubuntu. We've tested it and it is working for Ubuntu 16 and Ubuntu 18:

By default we were providing libraries that were giving problems. These libraries should be available by default in your computer.

Thank you, Albert,

Yes, the version available by then (3.5.0) was not working but with the newest version (3.5.4) it is working now.


Users browsing this thread:
1 Guest(s)