Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Unable to open .rdk files after using Educational License

I was working on a project in RoboDK until today when it decided it wouldn't open again. Up until now I was using the trial version, however I did have a valid educational license key purchased last January (still within the time-frame before maintenance). I entered in the license code (via Help->Licenses and entering in the server code) and it registered (it switched from the free version to educational while showing the University name). Despite this I am still unable to open any .rdk files. I will get the following message while trying to open up an example file I previously used:

[Image: Robo-DK-Error.png]
"Unable to access file .../RoboDK/Library/Example-01.a-Robot Painting - Universal Robots.rdk"

I would also like to mention some odd behavior hopefully useful for debugging the problem. When I closed the program after entering in the license key, it would reset back to the free version without remembering any of the licensing information. I could reenter the license key and it would change to the educational version until I closed the window. I still could not open any .rdk file. I uninstalled/reinstalled RoboDK. The license is remembered if I turn off RoboDK, but I am still unable to open .rdk files.

Let me know if you have any questions.
I will also add: My computer is running RoboDK v4.2.3 (64bit). No files can be added, including robot/end effector/python files. I have tried disabling my firewall and antivirus with no luck. My other computer with an expired free license can still open up files regardless (running v4.1.0 64 bit). I realize that this may be a bug (and I probably should have placed this thread in the bug board in hindsight).
Hi Ciaron,

Hope you are well.
The problem with the license reverting back to the "free license" is because you didn't have the "administrator" rights when you entered the license key.
To solve that problem, right-click the RDK shortcut and select "Run RoboDK as an administrator". Then enter the valid license key, that should solve the problem.

For the other problem, can you send us the .rdk file, please?
We will take a look and come back to you on it.
Hey Jeremy,

This is occurring with any file, including the pre-included example files, robot files, robot part files, and python files. I'll provide a file anyways.
Does it work if you start RoboDK with administrator privileges?
I have tried with Admin rights. The license is remembered as you said, but none of the files will open.

EDIT: I am able to open files by downloading and installing an older version of the software found at
I would however prefer the latest version.
This issue should not be related to the license.

Do you see the same problem if you load other files?
I have the same problem with RDK 4.2.4. I purchased educational licence and since then, I cannot access any file, nor save newly created station. Do you have any resolution for this issue?

For anyone concerned: I have reinstalled RoboDK and updated it to version 5.0.2. The error remained, even when I started RDK in admin mode. I managed to solve the issue by unselecting the "Read-only" property of parent folder containing the .rdk solution.
Thank you for letting us know about how you solved this issue.

(as we discussed, this issue should not be related to the license)

Users browsing this thread:
1 Guest(s)