Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Wrong Fanuc LS file syntax

#1
Hi All,

I have a problem with RoboDK making an LS file for my fanuc Robot. When I generate a programm (F6) the system forgets to translate ALL MoveL commands. (R30i postprosessor)

The MoveJ and the rest is ok so you can see in the attached picture.

When I ask my RoboDK distributer about this problem he shows me he don't have this problem with my file en at his computer also the moveL commalds are translated.

So its computer related, can someone help me please, I need to make / translate a lot of programm's 

thnx Willem


Attached Files Thumbnail(s)
   
#2
You can remove the default filter to generate one or more points that are too close to each other. 

You can remove this filter for all programs by following these steps:
  1. Select Tools-Options
  2. Select the Program tab
  3. Set Minimum step size to -1 mm for linear and joint movements.
#3
I changed the setting, see picture, but it did not do the job, stil the same.


Attached Files Thumbnail(s)
   
#4
Can you share the RDK file?

Are all the points exactly the same?
#5
See robodk file attached,

I think you can create the ls file with all point, my distributer also. But on my pc it doesn't work like mentioned above


Attached Files
.rdk   Lascel 2.rdk (Size: 830.24 KB / Downloads: 35)
#6
I was unable to reproduce this issue. To fix this issue about RoboDK filtering targets I recommend you to follow these steps:
  1. Make sure you update RoboDK to the latest version (or have a recent version installed)
  2. Select Tools-Options and click on Set default settings
  




Users browsing this thread:
1 Guest(s)