Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

autosetup does not transfer solid body and path has not reference frame

        I am trying out the sw plug-in and doing something like the robodk sample video.

I ran autosetup, picked the surfaces and curves for the path. but in robodk, the part is imported as a blank (no solid object).

and the curve is located at the robot base reference. it is not attached to a new reference frame and I cannot move it to the correct position.

please advise, thanks in advance.
I believe it is because you have the tool path in the robot base reference frame. Try moving the path into frame 3. Make sure frame 3 is the active frame as well. I could be wrong as I am new to this as well but I’ve had that issue before and it was because of the use of wrong reference frames

i would also use this video to help if you have not watched it already. I just made a program with an almost exact workspace as you and i had no issues. If you are still having issues i can try and help the best that i can.
Hi there,

First, there is two options for the path to be imported at the right place.
1 - You make sure the right reference frame is activated inside RoboDK.
2 - In SolidWorks, you open the RDK plugin settings and enter the name of the reference frame.

For the fact that the part is not showing, have you tried only using the "Load Part" option for the plugin?
If so and it's still not working, try changing the RDK plugin settings import file format from "Default" to "STEP".

Have a great day.
Thank you for all the replies. got it working. what made it worked was entering an object name under setting. when i enter a name for the object, the solid part gets inserted into Frame 2, and I was able to move the object with Frame 2.

In the robodk video, it didn't mentioned anything about setting (it only said that there will be a video about the setting coming later)

Good to know, I was not aware of that behavior.
I'll investigate.

And no, we didn't have the time to create the "Settings" video... And I know it's long overdue.

Have a great day.

Users browsing this thread:
1 Guest(s)