Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
avoid arcs function
#1
Hey guys,

I do have a question concerning the "avoid arcs" function in RoboDk.
I would like to convert a series of Move_Curve commands in smaller, linear Movements (and a lot of them).
For this I want to use the "avoid curve" function.

But when activated the generated krc4 Code is not what I would expect. There are 12 curve movements in total and after "avoiding curves" 12 linear movements (the same points), no further points were interpolated.

I attached the station for further reference.


Follow these steps to generate arcs as small linear movements:

1.Select ToolsOptions.
2.Select the Program tab.
3.Select Avoid arcs.
4.Specify the Maximum arc size (mm) which defines the size of the linear movements along the arc.

I interpret point 4 as the said "interpolation" function of the "avoid curves" strategy.

Thanks in advance
Hermann
#2
The maximum arc size will be the length of the small movements. More precisely, the length of the arc that is converted to a line. So this is not exactly the length of the line.

You forgot to attach your RoboDK project. If you can also provide a print screen of your Program settings we can better take a look.
#3
Thanks for the reply.
Attachments should be available now.


Attached Files Thumbnail(s)
   

.rdk   Unterlegscheibe.rdk (Size: 6.31 MB / Downloads: 42)
#4
*bump*
#5
I'm sorry for the delays on this issue. This was actually a bug with the default presets when you select Avoid arcs.

You should enter a small number in Minimum arc size (mm), such as 0.5 mm. You should enter an even smaller value in Maximum arc size (mm), such as 0.2 mm, to prevent generating arcs.

Let us know if this doesn't give you the expected result.

We'll be improving this default behavior with a new update this week.
#6
Yes, this does the trick....thank you Albert!
  




Users browsing this thread:
1 Guest(s)