Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

filtering is causing tool to wildly reorient

#1
A .src file works fine unfiltered, but when I drag&drop, "filter only", and run the filtered code, it's causing my tool to reorient by almost 180 degrees sometimes and impact the part.

I've been using this method problem-free for a couple months until today when it's destroyed three parts. I can't run a simulation of the code because all my targets are unreachable so I don't know if robodk knows it's screwing up the code.

The "A" rotation is 90 degrees different in this example.

Here are a few lines of functioning code, unfiltered:
Code:
$VEL.CP=0.35
LIN {X -365.644, Y 193.526, Z 809.626, A -169.333, B -87.933, C -98.11} C_DIS
LIN {X -416.455, Y 191.299, Z 800.698, A -139.053, B -89.531, C -128.387} C_DIS

and here is the same segment of code, filtered:
Code:
$VEL.CP=0.35
LIN {X -364.642,Y 193.278,Z 808.954,A -166.911,B -88.416,C -97.933,E1 50.00000,S 'B010'} C_DIS ; filtered
LIN {X -415.468,Y 191.056,Z 799.983,A -64.725,B -89.685,C -128.930,E1 50.00000,S 'B010'} C_DIS ; filtered

In the attached two files, it's lines 679 and 680.

To verify that the RDK station hasn't changed, I tried a backup of the RDK station from early February and had the exact same result. It's possible that something in Sprutcam changed, but I don't know what would make the filtering change sprutcam's output by an extra 74.328 deg - that doesn't really seem like a significant number. 1.3 radians?

Any ideas what's going on?
-Karl


Attached Files
.rdk   R2-v2.rdk (Size: 1.34 MB / Downloads: 194)
.src   R2.src (Size: 235.7 KB / Downloads: 159)
.src   R2_filtered.src (Size: 319.19 KB / Downloads: 157)
#2
We're going to try rotate A6 to 90deg and remaster only that joint (at 90°). Right now it's mastered at zero deg. Our other cell is set up this way and has no problems, so we'll try duplicate it to this problematic cell.
#3
I'm sorry to hear you had a crash. There is a strange issue with your Tool 1. For some reason, the tool does not hold a homogeneous pose. This means the orientation part of the pose is broken. You can find this out by following these steps:
  1. Double click Tool 1
  2. Select the Copy icon
  3. Select the Paste icon
You'll see a message saying "The matrix has been modified to match homogeneous matrix properties". This is related to the TCP orientation properties being incorrect. This could have happened for many reasons (pasting the full pose from a text file, using the API).

I attached the RDK project file with this fix. If you try filtering the program afterwards it should work without issues.

How did you teach your TCP? Did you use a specific add-in or custom script? We can better investigate to prevent this from happening again.

We just updated RoboDK for Windows and you should now see warning messages when you try to filter programs and this issue is detected.

I would still recommend you to use APT files instead. It is more clear for RoboDK to undertsand what Tool and Base frames you are using.


Attached Files
.rdk   R2-v3.rdk (Size: 1.34 MB / Downloads: 188)
#4
Thanks Albert,

the copy/paste values had the error exactly as you said. I define tools by right clicking the tool, clicking Define, then typing in 8 poses from the robot. If I want to add a tool, I right click a tool and copy/paste it, then right click the new tool and Define it. Maybe that's the problem?

Sprutcam can't export an APT file, I've been in contact with the support there about it. Not sure if it's coming any time soon.

Giving v3 a whirl now!
-Karl
#5
Thank you for your feedback! Let us know if you have any issues.

I believe Sprutcam should be able to export APT files. It should be one of many post processor they probably created for other customers.
  




Users browsing this thread:
1 Guest(s)