Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Admin Rights, RoboDK, and SolidWorks Plugin
#1
Is it possible to install the SolidWorks Plugin without requiring local administrative permissions?  Is it possible to install RoboDK without local admin rights?

My company IT department does not allow us local admin on "production" (connected-to-the-corporate-network) computers.  

I have RoboDK installed on a small single-board Windows 10 computer (a “Minisforum” PC from Amazon).  This is a stand-alone PC to which I do have admin rights, and it is not connected to our corporate network, only to our UR3e robot.  It does not have SolidWorks, but seems to run RoboDK OK.  However, when I try to zoom in to train very precisely located targets, I get some "screen clipping" where OpenGL displays only a section of my files.

I would like to try RoboDK on my corporate CAD machine since it has much more RAM, graphics capabilities, etc. but cannot install without admin rights.  Our RoboDK license is on a USB dongle, so I can move the license easily.
 
I would also like to generate CAD-to-path programs from SolidWorks, and my current process of exporting STEP files and moving from my corporate PC to the stand-alone PC via "sneaker net USB drive" is painful.  

Can you suggest any other work-around? Is it possible to build from source? 

Thanks,

Chris
#2
Hi Chris,

At what point do you need administrator rights?
Do you see the RoboDK plugin from SolidWorks?

The SolidWorks plugin should be automatically installed if you ran the RoboDK installer with administrator rights.

The manual install may be helpful if something went wrong.

Albert
#3
Sorry I wasn't more clear.  My situation:

PC#1: Underpowered PC, not controlled by corporate IT, I have local admin rights. Cannot install SolidWorks. RoboDK installed OK.  Having issues with screen "clipping", assumed to be due to lack of graphics resources.

PC#2: CAD-class laptop, controlled by corporate IT, NO Admin rights.  Has SolidWorks installed.  Cannot install RoboDK or SolidWorks Plugin due to lack of admin rights.
#4
Can you provide a screenshot of the screen clipping issue?
What are specs of your PC#1?

To debug the screen clipping better it would help if you can follow these steps:
  1. Close RoboDK
  2. Start RoboDK by double clicking the file:
    C:/RoboDK/RoboDK-Debug.bat
  3. Try to reproduce the problem and send us the file:
    C:/RoboDK/bin/RoboDK.debug.txt
#5
(04-15-2020, 10:12 PM)Albert Wrote: Can you provide a screenshot of the screen clipping issue?
What are specs of your PC#1?

To debug the screen clipping better it would help if you can follow these steps:
  1. Close RoboDK
  2. Start RoboDK by double clicking the file:
    C:/RoboDK/RoboDK-Debug.bat
  3. Try to reproduce the problem and send us the file:


Albert, Attached are the files you requested.  I also included the "test surface" STEP file I used.  

During the session captured in the log file, my steps were:

  1. Open UR3e robot
  2. Create new Reference_Frame
  3. Open test_surface.STEP file
  4. Drag test_surface onto Reference_Frame
  5. Zoom in to test_surface
  6. Observe screen clipping where sections of part disappear as I try to zoom closer to view small details, select curves, etc.  
    Discussion and Observations: At some zoom level, the part disappears completely.  Sometimes the zoom stops zooming.  Zooming out and back in causes erratic behavior, changing the point at which clipping or zoom-freeze occurs.  Hover the cursor over the geometry allows more zoom-in more before clipping.   Similar behavior occurs with fresh boot, fresh RoboDK session, and importing the STEP file only (skipping step 1 above where I import the robot).  I have also observed situations where I had significantly more geometry present (~500kB STEP files), and did not see dramatically worse behavior. Could it be that there is a "camera size" in the OpenGL implementation that is too large?
  • PC#1 is a Minisforum GN34:
  • Windows 10 Pro
  • x64 Celeron, 1.5Ghz, 4-core
  • 6GB RAM
  • On-board Intel HD Graphics Adapter, 1GB RAM
Thanks for your help!

Files attached (forgot to hit "Add Files" after "choose files").


Attached Files Thumbnail(s)
       

.txt   PC#1 Specs.txt (Size: 1.18 KB / Downloads: 52)
.txt   RoboDK.debug.txt (Size: 13.51 KB / Downloads: 56)
.step   test_surface_1_20200415-1138.STEP (Size: 35.2 KB / Downloads: 52)
#6
Hi,

For the clipping problem, try this real quick:

"Main menu"->"Tools"->"Options"->"Display"

There's an option "Don't display object smaller than", uncheck it if it's checked.
There's also the "Near - Far plane" option that can help.

Jeremy
#7
Jeremy,

During this test I had already changed the display options to:
  • "Don't display objects smaller than xx" = false
  • Near-Far plane (mm) = 0.1 - 100000

I have determined that the clipping issue is not likely due to my graphics RAM limitations.  I added a few more detailed tool models and part models to my station, and the performance was fine, in fact, I was able to zoom in to much more detailed ("real CAD parts") even closer before clipping occurred.  

Thank you for your help!  The live webinar yesterday was also very helpful.  Nice work RoboDK team!
#8
Hi Chris, 


This is strange. I have no clipping when importing your part. 
Here are my parameters. 
   

Jeremy
  




Users browsing this thread:
1 Guest(s)