Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CHANGE TYPE LIN TO PTP, ARC CIRCLE IN PROGRAM ROBOT
#1
Hi everyone,
I’m try running application follow curve profile with Robot Kuka KR6- R900. I have some problem need for help!
  • Change auto program from type Linear to PTP, Arc circle. Because type linear affects the actual running speed down of the robot.
  • I can’t change numbers path point in program. Is there any way to change number point?(please check attach)
#2
I believe you want to to use rounding/blending option to speed up the robot and also avoid jerky movements. See attached image to enable this option.
   

More information here:
https://robodk.com/doc/en/Robot-Programs.html#InsSmooth

You can also reduce the number of points per program here:
Tools-Options-Program-Limit maximum number of lines per program.

This will split long programs in subprograms (one subprogram in each file) so that you can easily run it on the robot.
#3
Thanks Albert,
I know why my robot low speed: main program set speed 1/20 speed of robot and disable set rounding.
I did "Tools-Options-Program-Limit maximum number of lines per program" but it changed 1 program to some programs not change number path point (robot run) in main programs.
#4
(10-31-2019, 10:26 AM)Albert Wrote: I believe you want to to use rounding/blending option to speed up the robot and also avoid jerky movements. See attached image to enable this option.


More information here:
https://robodk.com/doc/en/Robot-Programs.html#InsSmooth

You can also reduce the number of points per program here:
Tools-Options-Program-Limit maximum number of lines per program.

This will split long programs in subprograms (one subprogram in each file) so that you can easily run it on the robot.

Hi Albert,
Today I send my Program to robot's team test speed affter recommend of you. But actural speed Robot very slow(see link, the real speed is 100% Robot).
https://www.youtube.com/watch?v=RlfjEMJV...e=youtu.be
I have attach DKrobo file, please  help me.
Thanks!


Attached Files
.rdk   23.10-TEST 6.rdk (Size: 654.35 KB / Downloads: 10)
#5
Are you running in manual mode or automatic mode?

You can reduce the density of points in the following menu:
Tools-Options-Program-Minimum step size (mm)

The default value is 0.005 mm but you can increase it to 2 mm to see if it goes faster.

I don't think this is the reason though. Your points are not that close to each other. You may have a configuration variable limiting the robot speed.
  




Users browsing this thread:
1 Guest(s)