Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cant set port connecting to Kuka robot
#1
Hi,

I am able to control my kuka robot in the RoboDK GUI, but I cant figure out how to specify the port over the API. I am trying to use the robot.Connect function, which takes an IP address but not a port. 

I followed the advice in the link below to set a different rather than 7000 due to conflict with nginx.

https://robodk.com/doc/en/Robots-KUKA.html#DriverKUKA 

Thnaks!
#2
You can use the user interface to change the default settings (select Connect-Connect to robot). If you prefer changing these parameters using the API you can use robot.setParams to set the IP, port and other connection settings.
#3
I totally missed the robot.setConnectionParams API call last night, thanks Albert!
  




Users browsing this thread:
1 Guest(s)