Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Circular Blade Not Lifting before turning to cut next toolpath for DXF
#1
Hi Guys,

I am new to RoboDK. I have created 3 TCP on one tool attachment namely Waterjet TCP, Router TCP and a Circular Blade TCP and selected "Tool Orientation follows path" under TCP Settings for the Circular Blade TCP. I've imported a DXF with 3 layers (for the 3 TCP's). 
When simulating the Blade TCP the Blade turns 90 degrees at the corners of the workpiece whilst it is still inside the workpiece. I need to lift the blade at the end of each straight movement, then it must turn to the next straight Line toolpath direction whilst not moving, then it must move the "Z Final Mill Depth" and only then it must move to the end of the straight Line toolpath where it has to repeat the process until the last straight line is cut.

Any advice to achieve this will be appreciated?


Attached Files Thumbnail(s)
       
#2
Hi Curt,

The simplest option may be to load each cut separately as a different DXF file so you can apply an approach and retract for each straight cut.

How did you generate the DXF file?
Can you share the DXF and the RDK file?
We may be able to help you better.

Albert
#3
Thanks Albert,

I have shared the RDK file. However, I get an error message that the "Type of File that you attached is not allowed". The DXF file was created on Autocad 2007 and export as Autocad 2007 DXF file.

I have tried to load each Circular Blade cut separately by Ungrouping/Exploding all lines and shapes on the DXF drawing so that each cut is separate and then copied this file to the RoboDK station. I then selected "Edit Path Manually" but noticed that all four cuts for the Circular blade are still one shape. I am unable to select the cuts separately. Is that because the lines are connected even if it is not grouped together? See Shape 6 on the attached Circular Blade Path screenshot of the Edit Path screen.

Do I have to save a DXF file for each cut? If so, it will not be a "simple" process and waste a lot of time?

Surely there must be an easier option to make lines appear seperately on the Edit Path Manaully screen?


Attached Files Thumbnail(s)
   

.rdk   Kuka Station With Tools and Home.rdk (Size: 1.73 MB / Downloads: 108)
#4
Hi Curt,

Great, I see you are using DXF2Gcode. I also see that you have the saw cut as one path/layer.

It would be better if you can place each straight saw line in a different layer. In this case DXF2Gcode will automatically add an approach/retract move. 

The approach/retract distance is automatically set by DXF2Gcode can be changed here:
  • Options-Configuration-Machine config
You can also specify the cutting speed and approach/retract speeds.

Furthermore, you can customize the height for each layer/cut, speed, tool or other parameters, as shown in the attached image.

For example, if you name a layer like this:
MILL: 1 Md: 0 Sd: 0 FeedXY: 400 FeedZ: 200 RetractHeight: 100 SafeMargin: 100

You are specifying the retract/safety distance of 100 mm. You are also specifying the speeds, depth and step for each cut. More information here:
https://sourceforge.net/p/dxf2gcode/wiki/LayerControl/

Following this method you can define all the details in your DXF file and loading in RoboDK for robot simulation and programming should be immediate. You don't even need to open DXF2Gcode as the configuration is done automatically for each layer if you properly specify the layer names.

Albert


Attached Files Thumbnail(s)
   
#5
Thanks, the advice helped a lot!

Another question though: When using the MILL prefix a tool number can be selected in the layer name which is then used in the gcode. In RoboDK station we have 3x tools created namely (1) Blade (2) Waterjet (3) Router. In RoboDK we have named the tools instead of using numbers. How do I know which of these are T1, T2 and T3 so that I can already select the correct tool in my Layer name of the DXF drawing? This will save a lot of time.

I am hoping that I will be able to specify the tool number already in the layer name of the dxf drawing which will relate to the correct tools in RoboDK?
#6
Hi Curt,

You mentioned in another thread that your CAD software does not support the ":" character in the layer name. I would try with a dash "-". This setting can be configured here:
  • Options-Configuration-Automatic Tool config
The last image I attached in this thread shows this menu.

Albert
  




Users browsing this thread:
1 Guest(s)