Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Circular Blade rotates on last move before lifting up to safe height
#1
Hi Guys,

I am running a Kuka KR210 to cut stone countertops with a circular blade tool. 

Currently, we import all countertops sizes into a DXF file from a laser measurement system and nest it in the stock piece. We have created numbered layers in Autocad that contains all the required information for DXF2Gcode eg. feed speeds, cutting depths, slice depths, stock thickness, safe heights, retraction heights, etc.

We then select all the lines with similar directions in the DXF file and change their layers to be the same, starting with layer 1. Currently, the machine type is set as "Mill" in Dxf2Gcode. We then open the DXF file in DXF2Gcode, check the cutting directions and cutter compensation and then export each layer as a separate NGC Gcode numbered Mill01, Mill02, Mill03........

In RoboDk Tools>Options>CAM>Default Algorithm is set to "Tool Orientation follows path" so that the blade is always pointed in the cutting direction.

After updating the Mill programs, we combine them into a main program. This is how we do it currently. However, this is time-consuming and I am looking for ways to simplify the process.

The way to simplify the process is to use the DRAGKNIFE as the Machine type in DXF2Gcode. By doing this, we can only use 1 Layer for all the shapes in the DXFfile which saves a lot of time in the DXF file and also in DXF2Gcode as there is only one layer to export.

The dragknife setting works perfectly until the end of the last move. For all the other moves the tool direction is changed to the cutting direction at the safe height or extraction height, and then only the Z move is done into the stock. At the end of each move, the tool lifts up, changes tool direction to next cutting, moves down and start cutting. HOWEVER, at the end of the LAST move the tool direction rotates whilst it is still in the stock. This is a big problem for a Circular blade tool.

I have noticed in the NGC file attached that the rotational move is created by DXF2Gcode.
   
Please advise if there are ways to automatically remove the last rotational move? Or if there are any other ways?
Feel free to check the attached RDK file.

.rdk   Circular Blade rotates on last move before lifting up to safe height.rdk (Size: 9.92 MB / Downloads: 70)
#2
I would see at least 2 ways to take care of this automatically.
But it depends on the process you are using.

IF
You are generating the NC file with DXF2Gcode and saving it on your computer before loading it to RDK.
An NC file is just a text file, you could simply create a small python script reading the text file and remove/correct the last G3 you find, then load it in RDK (all of that could be done in one script, the modification and the loading.)

IF
You are loading the NC file in RDK directly from DXF2Gcode.
You could create the small Python script removing the last MoveC of the program you just generated.

But all in all, I feel like this might be a setting in DXF2Gcode as it's trying to turn back to the starting/home orientation?
I played a bit with this software, but I'm not a master. Do they have a forum or something where you could ask? That could potentially save you some coding.

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#3
Thanks Jeremy,

I took your advice to find a way in DXF2Gcode settings and made a simple fix.

In DXF2Gcode I have deleted the default input under Options>Postprocessor Configuration>Counter Clockwise feed move.

After that, the Problematic last move was no longer generated in the G-code.
#4
Great
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


  




Users browsing this thread:
1 Guest(s)