Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Connect to Fanuc rj3ic

Hello ,
I am trying to use roboDK with an Fanuc R-j3ic controller.
I have put the fanuc drivers on the fanuc , when i connect tot he robot with the ip address and port 2000 it say” connected “in green so that is ok.
Only when i click on get position then it disconnect.
Also when i jog the robot with the teachpendant i do not see the robot on the screen moving and also not see the values changing.
Hi Croesconnect,

I hope you are well.

Maybe I'm stating the obvious, but you need to make sure that the driver program (on the Fanuc controller) is actually running before sending the "Get Position" request.

Do you see any error message on the Teach Pendant?
In RoboDK connection window, there's "Show Log".
What does it say?

Hello Jeremy,

Yes, on the teach pendant i become an error " INTP-316 ( DRIVERRDK_S3, 129) Call program MEMO-088 Ptogram does not exist "

Hi Michel,

Did you follow these steps?

What version of the controller are you using?
Make sure to use the right version of the driverrdk_s3, there's a version for v6 to v8 and one version for V9 and higher.

hello Jeremy,

Yes, i follow those steps, and i tried also both versions of DRIVERRDK_S3.PC.
i can only connect to controller with the version v6-V8, version V9 gives an error on teach pendant.
the version of the fanuc controller is V7.

I tried also to get simple pos with python run on robot, then i become the same error on the teach pendant

when i get that error then i can not connect to controller any more ( disconnected ), then i must first abort all on the teach pendant and restart DRIVERRDK_S3.PC then it wil connect again.

Hi Michel,

I hope you are well.
Can you tell me what's at line 129?
(I don't have roboguide installed and TP file can't be read otherwise.)

The error code point toward a program not being loaded on the controller.
Did you load the the,, and on the controller?

Hi Jeremy,

Ok, i will look fryday to line 129.

and yes al the go_.... files are on the controller.

Hi Michel,

Ok, I'll wait for your feedback.
Again I might be stating the obvious, but you need to make sure that your "User Socket Messaging" and "PC Interface" options are active on your controller.

Hi Jeremy,

i can not see what is on line 129 of the driversdk_s3 because it is an pc file on the fanuc controller and not an karel source file.
do you know how to get the original driversdk_s3.kl karel file ?

Hi Michel,

I am having this same issue and was wondering if you ever found a resolution


Users browsing this thread:
1 Guest(s)