Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connecting RoboDK with Fanuc Roboguide simulator
#1
I want to set up the communication between RoboDK and Fanuc's robot simulation (Roboguide). I went through all the steps in the documentation, but I cannot make the program DRIVERRDK_S3 run. On the Robodk platform side, I can ping my simulator, but I cannot connect.

Has anyone tried that before?
#2
You probably need to activate User Socket Messaging option and PC Interface. If you still have issues, please send us a print-screen of the teach pendant after you attempt to run the DRIVERRDK_S3.
#3
All the options are set up. I tried 3 different methods to run the program and nothing happens, the teach pendant freezes for a minute or two and then everything comes back to normal, but I wasn't able to connect with RoboDK.
#4
What Fanuc controller are you using?
Can you provide a picture or video of the teach pendant when you try to run the program?
What setting do you have as Driver path? (in Connect-Connect to robot-More options)
Can you provide the RDK project?
#5
I cannot take a video of the teach pendant, because nothing actually happens except that Roboguide freezes. Here is the connect configuration and my project. Thanks


Attached Files Thumbnail(s)
   

.rdk   New Station (1).rdk (Size: 14.27 MB / Downloads: 91)
#6
The USB device can recognize DRIVERRDK_S3.PC, but when uploading it to the teach pendant, no upload error or failure is raised, but the program cannot be found in the teach pendant.


Attached Files Thumbnail(s)
       
  




Users browsing this thread:
1 Guest(s)