Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Connecting to Kinova

I am trying to connect to a Kinova gen 3 through roboDK using the robot driver.
I can ping it successfully, and have changed the driver file to be, but when I try to connect it fails and I get the following in the log

Quote:Starting robot driver: C:/RoboDK/api/robot/


Unexpected error: Traceback (most recent call last):

Unexpected error: File "C:\RoboDK\api\robot\", line 26, in <module>

Unexpected error: exec("from v" + version_str + ".apikinova import *")

Unexpected error: File "<string>", line 1, in <module>

Unexpected error: File "C:\RoboDK\api\robot\", line 87, in <module>

Unexpected error: File "C:\RoboDK\api\robot\", line 89, in DeviceConnection

Unexpected error: File "C:\RoboDK\Python\kortex_api\", line 12, in <module>

Unexpected error: from .Exceptions.KClientException import KClientException

Unexpected error: File "C:\RoboDK\Python\kortex_api\Exceptions\", line 1, in <module>

Unexpected error: from ..autogen.messages import Frame_pb2 as FramePb

Unexpected error: File "C:\RoboDK\Python\kortex_api\autogen\messages\", line 6, in <module>

Unexpected error: from google.protobuf.internal import enum_type_wrapper

Unexpected error: ModuleNotFoundError: No module named 'google'

Sending command...


Driver not connected


I have tried installing the google package  and that seems to be installed
Quote:C:\RoboDK\api\Robot\v310>pip install google

Requirement already satisfied: google in c:\users\bv1069\appdata\local\programs\python\python310\lib\site-packages (3.0.0)

Requirement already satisfied: beautifulsoup4 in c:\users\bv1069\appdata\local\programs\python\python310\lib\site-packages (from google) (4.12.2)

Requirement already satisfied: soupsieve>1.2 in c:\users\bv1069\appdata\local\programs\python\python310\lib\site-packages (from beautifulsoup4->google) (2.5)

I have checked that roboDK is up to date, and tried using it as a free trial and on our work license

any advice would be appreciated
Thank you
We are missing some dependencies to the kortex API in our latest builds.
We will add them shortly.

In the meantime, you can install required dependencies manually. Here's the official list:
Please read the Forum Guidelines before posting!
Find useful information about RoboDK by visiting our Online Documentation.

Users browsing this thread:
1 Guest(s)