Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connection fail with the Techman Robot
#1
Dear sir,

I'm trying to use RoboDK to connect TM robot with my laptop and control the robot directly in real time.
I follow the step below:
1. Select Connect➔Connect robot
2. Enter the robot IP
3. Enter the port 5890
4. Right click your program
5. Select Generate robot program F6.

But I still can connect the robot even I turn off all the firewalls.
I also open the cmd to ping the robot by my laptop, and the connection is no problem.
am I lost something?
The TMflow version I use is 1.82.5100.
Thanks.
#2
Can you do this instead?

Follow these steps to connect to the robot from RoboDK:

1.Right click the robot in RoboDK

2.Select: Connect to robot

3.Enter the IP of the robot and the port number

4.Select Connect.

There should be a green message displaying Ready if the connection succeeded. More on the link here: https://robodk.com/doc/en/Robots-Univers...l#DriverUR

Let me know if you still face issues.
#3
I already try the step you mention, but it still doesn't work.
I also refer to the video which is release on your youtube channel.
https://www.youtube.com/watch?v=2TJD1YyU...27&index=8

But I found a few different points:
1. I do not have a command button
       

2. My TMdriver.py has a different storage size than the video, Mine is 2kb, Video's is 41kb.
       

The attached video is my operation, please check if there has some mistakes.

Thanks!


Attached Files
.mp4   652327589.858072.mp4 (Size: 21.48 MB / Downloads: 11)
#4
I test with my colleague's computer, it works. I think it may be relative to python because I try to generate the path before, and I select the "Run script" function in the tools option to optimize the path. but it doesn't work.
  




Users browsing this thread:
1 Guest(s)