Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Curve and Linear tool paths. Rhino/Grasshopper
#1
I have two problems currently with my project. 

1) Angled Lines file- I am looking to have the tool head be perpendicular to the tool path.  I have tried various settings, and I can't seem to find a solution.  I'm sure there is a simple solution, but I can't seem to find it. 

2) Rhino and curves...  Robodk segments the curves, and I find my robot accelerating and decelerating at every node. Is there a simple way to bring either curves into Robodk and use the circular movement command, or are there other options? 

I would love to have tech support... Is there a way to have one-on-one support with someone, even if there is a rate?

See attached


Attached Files
.zip   Denso Station angled lines.zip (Size: 15.63 MB / Downloads: 23)
.zip   Denso Station blank.zip (Size: 16.2 MB / Downloads: 31)
#2
1) When you import the curve in RoboDK, select the curve and a surface you want the tool to be perpendicular of before clicking on Load Curve(s) in the Rhino plugin.

2) You can modify the curve import tolerances in the plugin Settings, but one another good option is to change the rounding value of the robot to a higher value, this should prevent the robot from decelerating between each targets. Do to this, double click on RhinoCrv Settings, open "Program Events" and change the rounding value. See the attached image.


Attached Files Thumbnail(s)
   
#3
Hello @Olivier

Thank you for your response!

Just to make sure that I understood you correctly for part 1. In my rectangular angled program, I should select one of the curves (i will choose the one closest to my work surface) make sure its highlighted then select Load Curves in rhino. Correct ?

Additionally, I will try changing the rounding value.
#4
Select the curve and a 3D model surface you want the tool to be perpendicular of in Rhino, then select the Load Curves in Rhino.
#5
Hello Olivier, 

I was able to get the angle to work! Thank you very much for the help.  I now have another question.  When I import the curves from rhino and run them on simulation it doesn't show the robot stopping at midpoints.  When I Run the robot from RoboDk the robot decelerates at every midpoint from the curve.. Is there a way to turn off midpoints and only have the corners?

Best, 
Austen


Attached Files Thumbnail(s)
   
#6
Are you still getting deceleration after modifying the rounding value in the Program events option?
#7
Hello Olivier,

I set the rounding to 5  and was still getting deceleration.  Is 5 a good number or should it be much higher?   My other concern is why doesn't the simulation show the robot stopping at the midpoints vs. when it operates in real life?  I can generate a video tomorrow (9/27/21) illustrating my issues with midpoints.

Best,
Austen
#8
Hello @Olivier

Here is a video link to the robot stopping at midpoints.  As well as the modified RDK

https://youtu.be/iDsG_coTIBk


Attached Files
.rdk   Denso Station Basic box.rdk (Size: 18.02 MB / Downloads: 22)
#9
The stop points you see is a limitation when using robot drivers. Not all drivers properly support smoothing the path.

Instead, I recommend you to generate the robot program file and send it to the robot. This is better for production purposes. I believe the Denso controller has an FTP server and you can send the files automatically by right clicking a program and selecting "Send program to robot".

Let us know if it does not work and we can help you send the program to the robot controller directly from your PC.
#10
Hello @Albert

I will give that a try here shortly. 

What I am noticing is that RoboDK is creating a point in the midplane of the lines. Is there a way to turn off midpoints and only have boundary reference points?  If I go into the program and delete all the mid points it runs fine. 

Best,
Austen
  




Users browsing this thread:
1 Guest(s)