Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Failed to Drip Feed Program Fanuc RJ3 Post

I get the following error from the drip feeding post processor. The Program generates the file and the last line has an indent. 

Any fixes to this issue?

Just upgraded to RoboDK v5.2.2 (64 bit), I was using v4.3.2 and the drip feeding process did not throw this error, however it would not upload the program to the controller.

Attached Files Thumbnail(s)
This is because you are using "Send program to robot" instead of using "Generate robot program".
You can't send a dripfeed program directly to the robot.

The dripfeed post-processor will create a Python file, most likely in "C:\Users\xxx\Documents\RoboDK".
You can then run this .py file to start the dripfeed.

Prior to generating the program, you also need to properly set the controller IP address in RoboDK.
1. Right-click a robot
2. Select "Connect to robot…"
3. Enter the IP of the robot

You also need to make sure the FTP server is properly set on the controller side:

Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel

I have generated the files and the python program exists to facilitate the drip feeding operation. I have setup the FTP client/server connection and am able to send programs to the controller via Filezilla, however before I upgraded I was able to FTP programs using the Fanuc RJ3 Post (direct from RoboDK using Send Program command), without drip feeding. Now I am having issues just sending the code...The same error is showing as in the first post.

For my information, do I run the program named or do I use the send to robot command from the GUI?

The error I recieve when trying to run the file is attached.

Attached Files Thumbnail(s)
The error you found was a small mistake on our end with the latest version.
Thanks a lot for pointing that out. This should be fixed with a new release by the end of the day. It will still be 5.2.2.

For the dripfeed you need to run the .py program.
Can you provide the generated .py file? I'll take a look to see what could be the issue on this one.

Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel

Glad to help.

Thanks Jeremy, I will download tomorrow and test it out. 

The program generated is attached. One more issue that I am having is that I would like to evaluate the Arc-Mate post but do not have this post processor. Can you please send this post-processor?
Okay I downloaded the link today and it removed the indent error.

I am still not able to send the program to the robot and I get this error (see attached) when trying to run the generated python script.

When I try to send program to program to the robot from RoboDK gui I get the 2nd error (attached image).
Which states the M_Print3D.TP is not able to send to the robot.

- AP

Attached Files Thumbnail(s)
Hi there,

i am currently having the same Error Message as shown in your secound immage.
Did you find a sollution for this?

I would be very happy about an answer.
Greetings Moritz
If you see an error message trying to send a program is probably because you have the program selected on the robot controller or it is running. I recommend you to reset the execution of your programs and select another program. You can also delete the program manually on your controller and you should be able to send the program again from RoboDK.

Users browsing this thread:
1 Guest(s)