Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Failed to generate program using the Mitsubishi Post Processor


I created a program and send it to robot corectly from my computer, but when I tried to do this from two another computers I got some errors:

1) File "C:/Users/xxx/AppData/Local/Temp/", line 58, in r.ProgSendRobot("", "/", "", "")

2) File "C:\RoboDK\Posts\", line 447, in ProgSendRobot AttributeError: 'list' object has no attribute 'lower'.

I don't know what I can do to fix this problem, especcially that I can send program from one computer with no problem.

Thanks for any help.
We fixed the file transfer issue with the post processor attached. Can you try again and let us know if you see any issues?

Attached Files
.py (Size: 4.35 KB / Downloads: 82)
Unfortunely I have another error, when I replace files.

NameError: Name 'RobotCom' is not defined.
Screen with actual errors (after replaced files).

Attached Files Thumbnail(s)
Try please this modified version of the post-processor.

Place please to the \RoboDK\Posts\
and Mitsubishi_mod.cpython-37.pyc to the C:\RoboDK\Posts\v37

I attached the files. If you have any issues, please let us know.

Attached Files
.py (Size: 2.24 KB / Downloads: 85)
.zip (Size: 9.31 KB / Downloads: 69)
I tried both the version from Albert which also leads to the RobotCom error and from Sergei which unfortunately leads again to the lower caser error from the original post. I switched to python 37 to get a smiliar setup.

Any hints what I might do wrong?

Thanks in advance
This issue should have been fixed with the latest version of RoboDK.

Can you download the latest version of RoboDK?
Thanks for the fast reply, I actually just yesterday downloaded and tried it with a mitsubishi RV-4, no files changed, just the original 5.6 clean install.
Could this have something to do with a different system python version? I have 3.10.5 installed.
Moving the joints worked the moment I switched to the system python version 310
Do you mean you switched to Python 3.7? Are you still have the issue with RobotCom?
Im sorry, my bad, i switched to 3.7 in robodk.. not 3.10
Moving the joints worked when I switched to 3.7 which came with robodk and not the systemversion which is 3.10

So with 3.7 selected as the interpreter and using sergeis files both .py and .pyc I end up with the "AttributeError: 'list' object has no attribute 'lower'"

Users browsing this thread:
1 Guest(s)