Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Failed to start - segfault
#1
robodk@sw1 ~/RoboDK/bin $ LD_LIBRARY_PATH=./lib gdb ./RoboDK 
GNU gdb (Gentoo 9.1 vanilla) 9.1
Copyright © 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://bugs.gentoo.org/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./RoboDK...
(No debugging symbols found in ./RoboDK)
(gdb) run
Starting program: /home/robodk/RoboDK/bin/RoboDK 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffe4138700 (LWP 2357)]
[New Thread 0x7fffdbfff700 (LWP 2358)]
[New Thread 0x7fffdb7fe700 (LWP 2359)]
No running instances of RoboDK detected
Starting  RoboDK  v 5.0.2 . 18542  ...
OS:  LIN64
Date build:  Aug 16 2020
Main process ID:  2353
Thread ID:  0x7ffff1cfa040
[New Thread 0x7fffd32aa700 (LWP 2360)]
Loading settings...
Failed to acces global parameters file
Setting up default settings...
Default settings set
Failed to acces global parameters file
Setting up default settings...
Default settings set
Settings loaded
Statusbar:  "Language set to English"
Updating recent files menu...
Created language menu
[New Thread 0x7fffd2806700 (LWP 2361)]
Setting slider style...
Done
Setting up graphics...
Setting up main window...
Starting main window...
LC start...
LC message:  LC device not found
Dongle not found or cannot read
LC start...
LC message:  LC device not found
Dongle not found or cannot read
Loading plugin:  "CollisionFreePlanner"
"libAppLoader.so"
"libCollisionFreePlanner.so"
Loading plugin file:  "libCollisionFreePlanner.so"
Loading plugin  "CollisionFreePlanner"
Using settings:  ""
Setting up the status bar
Inserting menu at the end of the utilities menu
Setting up the menu bar
"libOPC-UA.so"
"libPluginExample.so"
"libPluginGravity.so"
"libPluginPalletizing.so"
"libPluginRealTime.so"
"libRobotPilot.so"
List of LOADED plugins:
     "CollisionFreePlanner"
Done list of plugins
Statusbar:  "Loaded 1 plugins"
Reading preferred layout settings...
Done

Thread 1 "RoboDK" received signal SIGSEGV, Segmentation fault.
0x00007ffff67cd454 in QOpenGLContext::functions() const () from ./lib/libQt5Gui.so.5
(gdb) 




##########3

robodk@sw1 ~/RoboDK/bin $ modinfo nvidia
filename:       /lib/modules/5.5.0-gentoo-x86_64/video/nvidia.ko
alias:          char-major-195-*
version:        440.82
supported:      external
license:        NVIDIA
srcversion:     058C3165C621D73A1F7436F
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        ipmi_msghandler,i2c-core
retpoline:      Y
name:           nvidia
#2
I believe this issue is related to your graphic card drivers.
Are you using a virtual machine?
What operating system are you using?
#3
Nope.
Real machine.
Other OpenGL programs are OK.


QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-robodk'
Trying to run arguments on running instance... ("-NOSPLASH", "-DEBUG", "-SHOW")
No running instances of RoboDK detected
17:05:13.906 (+0 ms): RoboDK v5.1.0 debug file RoboDK.debug.txt, started on 08-10-2020-17:05:13.906
17:05:13.906 (+0 ms): Debug: OS:  LIN64
17:05:13.906 (+0 ms): Debug: Date build:  Sep  7 2020
17:05:13.906 (+0 ms): Debug: Main process ID:  27568
17:05:13.906 (+0 ms): Debug: Thread ID:  0x7fcd972d5bc0
17:05:13.906 (+0 ms): Debug: Loading settings...
17:05:13.906 (+0 ms): Debug: Failed to acces global parameters file
17:05:13.906 (+0 ms): Debug: Setting up default settings...
17:05:13.907 (+1 ms): Debug: Default settings set
17:05:13.907 (+0 ms): Debug: Failed to acces global parameters file
17:05:13.907 (+0 ms): Debug: Setting up default settings...
17:05:13.907 (+0 ms): Debug: Default settings set
17:05:13.907 (+0 ms): Debug: Settings loaded
17:05:13.963 (+56 ms): Debug: Statusbar:  "Language set to English"
17:05:13.966 (+3 ms): Debug: Updating recent files menu...
17:05:13.971 (+5 ms): Debug: Created language menu
17:05:13.984 (+13 ms): Debug: Setting slider style...
17:05:13.985 (+1 ms): Debug: Done
17:05:13.999 (+14 ms): Debug: Setting up graphics...
17:05:14.000 (+1 ms): Debug: Setting up main window...
17:05:14.000 (+0 ms): Debug: Starting main window...
17:05:14.015 (+15 ms): Debug: LC start...
17:05:14.015 (+0 ms): Debug: LC message:  LC device not found
17:05:14.015 (+0 ms): Debug: Dongle not found or cannot read
17:05:14.015 (+0 ms): Debug: LC start...
17:05:14.015 (+0 ms): Debug: LC message:  LC device not found
17:05:14.015 (+0 ms): Debug: Dongle not found or cannot read
17:05:14.016 (+1 ms): Debug: Loading plugin:  "CollisionFreePlanner"
17:05:14.016 (+0 ms): Debug: "libAppLoader.so"
17:05:14.016 (+0 ms): Debug: "libCollisionFreePlanner.so"
17:05:14.017 (+1 ms): Debug: Loading plugin file:  "libCollisionFreePlanner.so"
17:05:14.017 (+0 ms): Debug: Loading plugin  "CollisionFreePlanner"
17:05:14.017 (+0 ms): Debug: Using settings:  ""
17:05:14.017 (+0 ms): Debug: Setting up the status bar
17:05:14.025 (+8 ms): Debug: Inserting menu at the end of the utilities menu
17:05:14.025 (+0 ms): Debug: Setting up the menu bar
17:05:14.025 (+0 ms): Debug: "libOPC-UA.so"
17:05:14.026 (+1 ms): Debug: "libPluginExample.so"
17:05:14.026 (+0 ms): Debug: "libPluginGravity.so"
17:05:14.026 (+0 ms): Debug: "libPluginPalletizing.so"
17:05:14.027 (+1 ms): Debug: "libPluginRealTime.so"
17:05:14.027 (+0 ms): Debug: "libRobotPilot.so"
17:05:14.027 (+0 ms): Debug: List of LOADED plugins:
17:05:14.027 (+0 ms): Debug:      "CollisionFreePlanner"
17:05:14.027 (+0 ms): Debug: Done list of plugins
17:05:14.027 (+0 ms): Debug: Statusbar:  "Loaded 1 plugins"
17:05:14.027 (+0 ms): Debug: Reading preferred layout settings...
17:05:14.027 (+0 ms): Debug: Done
17:05:14.027 (+0 ms): Debug: Updating window title...
17:05:14.027 (+0 ms): Debug: Entering main loop
../RoboDK-Start.sh: line 7: 27568 Segmentation fault      ./RoboDK -NOSPLASH -DEBUG -SHOW



gdb shows:
Thread 1 "RoboDK" received signal SIGSEGV, Segmentation fault.
0x00007ffff67ca454 in QOpenGLContext::functions() const () from /home/robodk/RoboDK2/bin/lib/libQt5Gui.so.5
(gdb)
#4
This issue seems to be related to OpenGL drivers...

Can you reproduce the crash with the latest RoboDK version for Linux?
#5
More recent than this ?

17:05:13.906 (+0 ms): RoboDK v5.1.0 debug file RoboDK.debug.txt, started on 08-10-2020-17:05:13.906

SOLVED

Pardon me. Permissions on /dev/dri was wrong, causing the segfault instead of error message.
  




Users browsing this thread:
1 Guest(s)