Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Having problem connecting to Yaskawa robots
#1
Hi,

I'm trying to use RoboDK to control Yaskawa robots, but I'm having problem connecting to the robot. I'm following the RoboDK document: https://robodk.com/doc/en/Robots-Motoman.html#Motoman

PC
- IP: 192.168.255.1
- Tested RoboDK under both Windows and Ubuntu

Yaskawa GP7:
- IP: 192.168.255.2
- YRC1000micro
- ping test: success
- cannot connect with message "robot took too long to respond" or "connection problems"

Yaskawa GP25:
- IP: 192.168.255.2
- YRC1000
- ping test: success
- cannot connect with message "robot took too long to respond" or "connection problems"

Intestingly, I can connect to MotoMini, with YRC1000micro/192.168.255.2. 

Since I can connect to MotoMini/YRC1000micro all right, I think there's some settings missing in GP7/25, but I cannot seem to figure it out.

Any help would be appreciated

Sincerely,

Steve


Attached Files Thumbnail(s)
       
#2
Did you set the robot in Remote mode on your teach pendant?

I'm not sure I understand what robot controllers you can connect successfully and the ones you can't. The connection to a robot mostly depends on the robot controller, not the robot model. The Motoman HSE protocol is available depending on the controller and you should be able to connect to the robot from RoboDK without using MotoCom.
#3
Hi Albert,

Thank you for the reply. Yes my robot is in REMOTE mode. It seems that my GP7 does not have high-speed ethernet server function. I will check with the local distributor and update/delete this post once the issue is resolved

Regards,

Steve
  




Users browsing this thread:
1 Guest(s)