Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Import Large CAD file robot station
#1
Hello,

I'm having a problem with importing large CAD files. I have a .iges file. A fully designed workstation (screw machine, conveyor, table etc) and I want to import this in RoboDK to add the robot and start programming. The file size of the .iges is 500mb. After a while the file is imported in RoboDK but e.g. rotating takes forever. i have a pretty good laptop assembled for professional use (I7, 8gb ram etc.). Is there workarround or am I doing something wrong?

Kind regards,

Stijn.
#2
Hi Stijn,

I recommend you to change this setting:
  • Tools-Options-CAD
  • Select Fast Import settings
  • Reload your IGES or STEP file so the mesh is lighter
More information here:
https://robodk.com/doc/en/General.html#ImportSTEPIGES

Sometimes, when you load geometry, some surfaces may be duplicated. Can you send your IGES or RDK file? We can help you better.
#3
Hello Albert,

thank you for your explanation. I've tried the "fast import settings". Still a very large and slow file.
I'll PB you the download link for the files.

Kind regards,

Stijn.
#4
Hi StijnM,

What's the file size?

Here's what you can do. Open a new station.
"Tools"->"Options"->"Display"->"Display text on screen" -> Enable "Render time"
You will see the FPS count bottom left of your screen. (This is just to see improvements)

Import the file with the fast-import settings.
Try to move the object/view and look at the frame count. (FPS)
Double-click the part.
"Object panel" to your right.
"More Option" -> "Change color"

The numbers on the colors represent the number of polygons that need rendering.
The hight the number, the bigger the wait.

Sometimes you will find one color (generally grey) that has more polygons than the rest.
This is often because surfaces were imported twice.
I recommend clicking the color and dropping the Alpha channel to 0.
You will see if this removes or reveals details.
If those surfaces were not needed you can go back to the "Change colors" window, right-click the color and "Delete mesh".
Get rid of any unnecessary color/polygons.

Close this window and see if it made a difference to the frame count (FPS).

If it's still heavy,
"Tools"->"Options"->"Display"
Enable "Don't display object smaller than" and try with a value below 1.5%.

If it's still heavy,
"Tools"->"Options"->"Display"
"Display performance" -> "Simplify Objects" -> "Select the object".

Let me know if it helped.

Jeremy
#5
Hi Jeremy,

The size is 512mb. I already exported the separate elements as .ply files and imported them separately. This already helped.

I'll check the settings tomorrow at work. Today I did the following which also already helped a little:

right mouseclick on the desktop -> NVIDIA control panel -> Manage 3D settings -> Program settings -> select program to customise -> add -> RoboDK

Select the preferred graphic processor:
High performance NVIDIA processor

Apply settings.

Regards,

Stijn.
#6
Hi Jeremy,

I've tried your options, The effect is minimal. However If I set all the imported 3D objects to invisible except the one I'm working on it can be done.

Thank you for your explanation.

Regards,

Stijn
  




Users browsing this thread:
1 Guest(s)