Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is it possible to import STEP files with coloring?
#1
The step models for a lot of my parts have coloring already included in them, but when I import into roboDK I always get a white part.  Is there a way to keep coloring when importing?  I'm coming from fusion360 with most of my parts if that makes a difference and I've verified that the exported STEP files do indeed have color included.
#2
I recommend you to specify the STEP 214 format if you can.

Also, try to avoid adding material to your 3D models. This can create duplicate objects with different colors and may make the cell very heavy.

More tips here:
https://robodk.com/doc/en/General.html#FastFPS
#3
I can confirm i'm exporting step 214 files and that they have color (it shows up in other tools).  but the color does not appear in roboDK
#4
(04-30-2020, 02:50 AM)chris_UW Wrote: I can confirm i'm exporting step 214 files and that they have color (it shows up in other tools).  but the color does not appear in roboDK

I did some more testing and apparently things i make from scratch with all faces the same color are working. But steps with colored faces seem to not work.
#5
Hi Chris,
This is usually because you have to color on top of one another.
"Double click the object" -> "More Option" -> "Change colors" -> Try deleting the "grey" that covers everything.

It usually works.
Jeremy
#6
(04-30-2020, 06:21 AM)Jeremy Wrote: Hi Chris,
This is usually because you have to color on top of one another.
"Double click the object" -> "More Option" -> "Change colors" -> Try deleting the "grey" that covers everything.

It usually works.
Jeremy

ah!  That did it.  It also deleted about 40% of my particular object (meca500's gripper).  Perhaps I can modify it in fusion360 and try again now that i know the colors are actually there.
#7
(04-30-2020, 05:40 PM)chris_UW Wrote:
(04-30-2020, 06:21 AM)Jeremy Wrote: Hi Chris,
This is usually because you have to color on top of one another.
"Double click the object" -> "More Option" -> "Change colors" -> Try deleting the "grey" that covers everything.

It usually works.
Jeremy

ah!  That did it.  It also deleted about 40% of my particular object (meca500's gripper).  Perhaps I can modify it in fusion360 and try again now that i know the colors are actually there.

Incase it helps people in the future, I was able to turn the alpha down from 255 to 252 on that outer layer covering all the other colors and everything looks right now.  I guess that changed the rendering order or something.
#8
Thank you for your feedback.

You should also be able to right click an object, select Split Object and delete duplicate geometry. This usually happens if you add material properties to your 3D models. You can later select all sub components and select "Merge".
  




Users browsing this thread:
1 Guest(s)