Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kuka KR16-2 MoveL $Base problems.
#1
Hello,

I am having some problems with my KR16-2 KRC4 (KS V8.2) Robot. Initially, any moveL commands will cause the robot to drift and collide with itself, while moveJ worked fine. I noticed that the Base was not changing to 1 on the HMI. 

I followed the instructions under RoboDK driver for Kuka: KUKA robots - RoboDK Documentation and updated the robodk driver and sync code.
The values and numbers for tool and base in the controller and software are matching and Provide Cartesian coordinates with respect to the reference is enabled.
Unfortunately the problem persisted, the base remained at 0 (nullframe). 

I tried variations of the robodksync542 code as follows:

$BASE = {FRAME: X 0,Y 0,Z 0,A 0,B 0,C 0}
$BASE = BASE_DATA[1]

bas(#base, 1)

Of these three, bas(#base, 1) worked to change the base to 1 and "Provide Cartesian coordinates with respect to the reference" must be enabled. bas(#tool, 1) must be set too.

The robot does not drift anymore, however, all machining projects are fixed to the origin of the base. If I move the curve, the robot ignores the offset and conducts the machining at the origin.

Also, I had to comment out "DECL INTERRUPT 5 WHEN $IN[1] DO ProbeTriggered()" on the robodksynce542 code as I receive an "illegal or unknown block" error on the HMI.


Please advise if there is a solution for the problems listed.
Thanks for your support, Kind Regards, Daniel. 
#2
The KUKA SRC BAS function will define the base and machine definition you use. This is defined in the $config.dat and $machine.dat files.

Activating the setting in Tools-Options-Driver-Provide Cartesian coordinates with respect to the reference makes RoboDK not calculate the position with respect to the robot base (as it does by default), and leaves it with respect to the reference the target is attached to.

I recommend you to make this work with a sample program offline as it will help you find out how the coordinate systems and external axes are built in the controller and make sure this is properly defined in RoboDK (I assume you have external axes synchronized).

Also, try to make sure you selected the reference attached to your part in your robot machining project.

Can you provide us with your RoboDK project file? We may be able to help you better.
#3
Thanks for the reply.

References are all set in machining projects and labelled correctly (LaserCutterBase 1) as far as I can tell. 

I will only use 1 tool and base for this project and are set to #1 in robodk and the krc4 controller.

I've attached my robodk file and a video with the robot running.

Kind regards, Daniel


Attached Files
.rdk   KR16-2 Laser Cutter.rdk (Size: 8.08 MB / Downloads: 32)
.mp4   KR16offsetmovements.mp4 (Size: 2.99 MB / Downloads: 33)
  




Users browsing this thread:
1 Guest(s)