Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Motoman alarm 4201 (19)
#1
Alarm 4201(19) - The number of steps added to a job exceeded 9999

I have changed the program to only generate 5000 line, but I still get programs that are too big to load. When I look at the files they are 9997 lines long or even longer.
I have attached what file I could from the file generated by RoboDk. 

How do I load these to be able to run them?

I also have other issue that i need answers too, but the forum only allows me to post 4 times. How else can I get support and the answers I need to make the software as productive ass possible? I have been to the online documents and have reviewed the youtube videos, but they do not address the issues I am having.

Tks


Attached Files
.jbi   M_Run48.JBI (Size: 486 bytes / Downloads: 35)
.jbi   Run4884.JBI (Size: 375.24 KB / Downloads: 17)
.jbi   Run48842.JBI (Size: 376.17 KB / Downloads: 18)
.jbi   Run48843.JBI (Size: 374.39 KB / Downloads: 14)
.jbi   Run48844.JBI (Size: 370.61 KB / Downloads: 15)
.jbi   Run48845.JBI (Size: 374.47 KB / Downloads: 18)
.jbi   Run48846.JBI (Size: 376.17 KB / Downloads: 19)
#2
If you own a professional version of RoboDK, you can reach us through "Help"->"Request support".

Which post-processor are you using?

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#3
Motoman post processor
#4
With the Motoman post processor, the limitation is the number of instructions (not the lines of code in your program). Since you'll have one position register in the header for each movement, the final size of the file will be approximately twice your limit. I recommend you to reduce the number of lines per program a bit more. For example, 4000 to be safe (I noticed RoboDK's default limit for Motoman robots is 2000).

Also, how are you generating your toolpaths? Depending on your robot and your manufacturing operations I recommend you to reduce the density of generated points by changing this value:
  1. Select Tools-Options
  2. Select the Program tab
  3. Select the Coarse option in the section Output for linear movements. Or set the Minimum step size to 0.5 mm or larger depending on the accuracy you need.
More information here:
https://robodk.com/doc/en/Robot-Programs...abSettings
  




Users browsing this thread:
1 Guest(s)