Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MoveJ malfunction for synchronized robot
#1
Hi, I'm having some problems with using the command moveL when synchronizing the robot with the turntable. If I run the program simulation on RoboDK, everything works well, but when I run it with "run on robot", it doesn't follow the path line and seems to execute moveJ command instead of movL. However when I remove the synchronization, it goes back to normal. I wonder if there is anything wrong with the moveL command for a synchronized robot?
Hope to hear from you guys soon!
#2
Setting up an external axis may require changing some settings depending on the robot controller. You may need to properly configure your cell in RoboDK and your controller so they both match.

What robot controller are you using? If you can share your RoboDK project file we can better take a look.
#3
(07-03-2022, 02:18 PM)Albert Wrote: Setting up an external axis may require changing some settings depending on the robot controller. You may need to properly configure your cell in RoboDK and your controller so they both match.

What robot controller are you using? If you can share your RoboDK project file we can better take a look.

Hi Albert, I'm using Motoman robot ES200N with DX100 controller for testing external axes synchronization. I've attached 2 videos recorded when I ran the program on the robot for a deeper understanding of the problem.


Attached Files
.rdk   test1.rdk (Size: 1.24 MB / Downloads: 32)
.mp4   2022-06-30 15-51-15.mp4 (Size: 6.55 MB / Downloads: 22)
.mp4   2022-07-01 09-27-51.mp4 (Size: 1.95 MB / Downloads: 17)
  




Users browsing this thread:
1 Guest(s)