Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MoveL failing on Kuka robot, ROBODKSYNC543 crashes, COM_E6POS invalid
#1
Hi, 

I just got my robot running today and all the MoveJ calls look great. However, when I call MoveL, the ROBODKSYNC543 process on the controller crashes with the error message "COM_E6POS value invalid". I have run this code extensively in simulation and everything works well. I have attached a picture of the controller error message.

It looks like some other people have run into this issue, but I am still not sure what the fix is.

https://robodk.com/forum/Thread-MoveL-is...=COM_E6POS
https://robodk.com/forum/Thread-MoveL-no...=COM_E6POS

I am new to Kuka and online programming with robodk, so if there is anything special I need to configure about my tool, I probably have not done that. 

The RoboDK connection log does not show much, besides that it freezes on "Working..."
Code:
Sending command...
Working...
Ready
Sending command...
Working...


As always, thank you for the help!
#2
Hi,
Can you tell us which KUKA driver do you use? apikuka or kukabridge?
You can find out by clicking More options in the Connect to Robot window...
[Image: img14.png]
If you are using the apikuka driver, click the Select button and switch to the kukabridge driver.
#3
Hi,

Thank you for the advice. Unfortunately, it does not look like I have access to this driver. I am running RoboDK under Linux and am using version 5.5.0 from 8/29. From the release notes, it looks like the new client might have been released on 2022-09-07?

I posted a few days ago about updating the linux binaries. I believe I am on the latest version available for download on the website: https://robodk.com/forum/Thread-Update-linux-binaries

Second question, is it possible to select drivers over the API? I am generally running robodk headless.

Thank you,
Rick

Thank you,
Rick
#4
As a temporary solution I can try to build a Linux version of kukabridge for you.
You can just replace the content of the apikuka driver without changing the file name.
What version of Linux and the Qt Framework do you use?
#5
I am running Ubuntu 22.04 and I thought QT was packaged with Robodk 5.5.0, not at my computer to check anything more specific at the moment.
#6
I tried to work around this today running KukaVarProxy on the robot controller, but got a similar error.
#7
The main issue you brought up (COM_E6POS not defined) happens because you did not declare the COM_E6POS as a global variable.

This line should be in the global definitions KRC:\R1\SYSTEM\$CONFIG.DAT:

Code:
DECL E6POS COM_E6POS

We improved the drivers recently so if you followed the configuration steps previously you need to add this line.

More information here:
https://robodk.com/doc/en/Robots-KUKA.ht...iverConfig
#8
Hi Albert,

I believe I have that set correctly. I have attached both a picture of my $CONFIG.DAT file and a screenshot of the interface when the program crashes. I copy and pasted the $CONFIG.DAT files from the website because at one point I was having trouble with the auto configuration option.


Attached Files Thumbnail(s)
       
#9
Hi Rick,
Try the kukabridge driver (attached to this post) with the C3 Bridge Interface on the controller side (download link: https://robodk.com/doc/drivers/Connect-K...RoboDK.zip, use c3setup-1.6.1.exe or the standalone version c3bridge.exe).
You can rename kukabridge to apikuka in case you don't use GUI (don't forget to make a backup copy of apikuka).
The kukabridge will not work with KukaVarProxy, so don't use it.
The apikuka can work with KukaVarProxy and C3 Bridge Interface, but the latter is preferable.

Best regards,
Dmitry.


Attached Files
.zip   kukabridge_ubuntu64.zip (Size: 115.9 KB / Downloads: 24)
#10
Amazing, that worked. Thank you Dmitry! That also fixed https://robodk.com/forum/Thread-getDI-io...UKA-driver
  




Users browsing this thread:
1 Guest(s)