Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PostProcessor - Tweaks
#1
I am having some problems linking a custom post-processor with the actual ls file generated in RoboDK. Somehow the changes I made to the *.py file in RoboDK do not reflect in final '.ls file. Here are some details...

In the latest version of RoboDK, I modified the python file Fanuc_RJ3.py and added the parameters we need to run our robot, see below (specifically the CNT_VALUE):
 
# set default joint speed (percentage of the total speed)
    JOINT_SPEED = '50%'     
    # set default cartesian speed motion 
    SPEED = '200mm/sec'     
    # set default CNT value (all motion until smooth value is changed)
    CNT_VALUE = 'CNT100'
    # Active UFrame Id (register)
    ACTIVE_UF = 6           
    # Active UTool Id (register)
    ACTIVE_UT = 6           
    # Spare Position register for calculations (such as setting UFRAME and UTOOL)
    SPARE_PR = 10
 
Then, in my Robot Advanced Parameters, I set the post-processor to FANUC RJ3 (in the provided drop-down list) - see attached file. However, when I create an LS file (using this post-processor), the JOINT_SPEED is set at 2% instead, see below:

   8:  PR[10,1]=1799.300 ;
   9:  PR[10,2]=0.455 ;
  10:  PR[10,3]=-796.201 ;
  11:  PR[10,4]=0.040 ;
  12:  PR[10,5]=0.163 ;
  13:  PR[10,6]=90.000 ;
  14:  UFRAME[6]=PR[10] ;
  15:  UFRAME_NUM=6 ;
  16:  PR[10,1]=0.000 ;
  17:  PR[10,2]=-407.750 ;
  18:  PR[10,3]=251.000 ;
  19:  PR[10,4]=90.000 ;
  20:  PR[10,5]=0.000 ;
  21:  PR[10,6]=0.000 ;
  22:  UTOOL[6]=PR[10] ;
  23:  UTOOL_NUM=6 ;
  24:  ! Show TCP_MNM2 ;
  25:J P[1] 2% CNT100 ;
 
Can anyone help me identify what I am missing in this whole setup?


Attached Files Thumbnail(s)
   
#2
Hi WRLS_DK,

Can you provide the custom post-processor, please?
That would help me help you.

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


  




Users browsing this thread:
2 Guest(s)