Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RoboDK crashes a lot
I am using roboDK for a couple of weeks now and since I installed it is crashes a lot. First I thought it was due to the test license, but the same thing happens with the full license as well.

I tried it on two different mac's with the same issues.
And installed the newest version downloaded and installed today.

I ran "/RoboDK/" with the following error:
22:40:45.587 (+2710 ms): Debug: Adding new docked window:  "Frame Details: Rotation Base"
22:40:45.588 (+1 ms): Warning: QMainWindow::addDockWidget: invalid 'area' argument
/Applications/RoboDK/ line 3: 51840 Segmentation fault: 11  ./RoboDK -DEBUG

The crashes appear when I close a window, either "mechanism control panel" or  "Frame details" window.
I hope this gives you enough information to explain me what to do and how to solve it.

Thank you for letting us know. We'll be looking at this issue in the next few days and we hope to fix it soon.

Hi Albert,

Thanks for the update, please let me know if you need more information or if I need to try something.

I was unable to reproduce this issue.
Can you provide the complete log file?
Does it always happen or is this issue specific to a project?
I noticed a specific moment when it happens.
It is all on closing windows and especially when the windows are not selected before closing.

Maybe that helps?
In the meantime I will create another logging file and sent it to you together with the other file (other question on forum)

I too have experienced some crashes using RoboDK on a MAC.
A crash that I am able to repeat is as follows. 
I created a simple MainProgram, added a 'Set Speed Instruction', and when I attempt to move the instruction among other programs, I immediately and consistently get a crash. 
I ended up creating a SetSpeed program, with only a Set Speed Instruction, and placed it among other programs where I wanted it, then I created my MainProgram.
These issues should now be resolved for all platforms (Windows, Mac and Linux).

Let me know if you still see related issues and we'll fix them as soon as possible.
Dear Albert,

Thanks for the update! I installed it and gave it a quick try. No issues in the first minutes. But after a while it freezes up again.
I'll make a logging like before later on.


Users browsing this thread:
1 Guest(s)