Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RoboDK driver for ABB
#1
I was following these steps to set up the RoboDK driver for ABB robots at the following link.
https://robodk.com/doc/en/Robots-ABB-Rob...#DriverABB 

1.Connect the computer to the robot using an Ethernet cable (or RS232 connection if you are planning to use serial connection). [For this, I used a service port of the ABB IRC5 controller to connect to my computer.]
2.Load the RDK_DriverSocket.mod module to the robot (using a USB drive, FTP transfer or RobotStudio). It should be used as the main task and this module already contains the Main program call. [This is where I have a problem. I do not know where to find 'RDK_DriverSocket.mod'.]

Would appreciate it very much if someone helps me with this.

Thanks and regards,
Win
#2
Hi Win,

Just follow this link : https://www.robodk.com/doc/drivers/Conne...RoboDK.zip

Have a great day.
Jeremy
#3
(08-15-2019, 01:39 PM)Jeremy Wrote: Hi Win,

Just follow this link : https://www.robodk.com/doc/drivers/Conne...RoboDK.zip

Have a great day.
Jeremy

Thanks a lot for your quick help!

Appreciate it!

Regards,
Win
#4
(08-15-2019, 01:39 PM)Jeremy Wrote: Hi Win,

Just follow this link : https://www.robodk.com/doc/drivers/Conne...RoboDK.zip

Have a great day.
Jeremy

Hi Jeremy,

I having some issue when I trying to use this ABB driver:
I am using IRB660 to test this.  Using RDK_DriverSocket.mod. I am able to connect (Robot IP: 192.168.125.1, Port: 2000). RoboDK Version: 5.0.2.18554

1) Click on the "Get Position Icon, A6 is always show "0", I tried to jog robot using flexpendent (ABB teach pendent) to jog robot in different position and click on get position, the A6 still get 0. And robot position is not tally with the actual robot (axis value).

2) When click on "Get Position" The quarternion value is not tally with the actual value shown at flexpendent. But "XYZ" position is same.

3) I tried to do it other way, key in the value shows at the flexpendent (ABB quaternion) to Robot option panel (RoboDK). And I get the correct joint value, and the robot position in RoboDK is exactly same as actual robot.

4) Set the RoboDK to HOME (in Joint Axis Jog). Click "Move Joints". Robot move to HOME position perfectly (tried from few different position jog by flexpendent then "Move Joints" to home).

5) Try Jog robot in RoboDK in cartesion (XYZ) in RoboDK, and click on "Move joints" (Try During at HOME point).
5.1) Move along Robot X-axis, OK
5.2) Move along Robot Y-axis, NOT OK, Not same as actual.
5.3) Move along Robot Z-Axis, OK

6) Try Jog robot in RoboDK in Axis in RoboDK, and click on "Move joints" (Try During at HOME point).
6.1) Axis 1, NOT OK. Axis 6 will move (I only jog A1 10, A2 0, A3 0, A6 0)
6.2) Axis 2, OK;
6.3) Axis 3, OK;
6.4) Axis 6, NOT OK. Axis 6 not moving at all.

7) I try to Jog robot in RoboDK in Axis 1 with 1 degree. Found that the Axis 6 is rotate 33.33 degree (in actual robot)

8) I tried to generate program and transfer program to Robot via USB. No problem, robot move as per RoboDK.

I hope the above testing might helpful for you to resolve my issue. If you need further info, I will try to connect to the robot and test.

Thanks,
CY Ching
#5
Hi CY Ching,

Thank you for such a detailed description of the issue.

I believe this is related to version mismatch. Can you try installing the latest version of RoboDK?
https://robodk.com/download

Albert
#6
hallo,

i have tried to connect a ABB Robot via serial connection to a pc with RoboDK. for this i have used the "RDK_DriverSerial.mod" driver from this thread. i think a part of the syntax isn't compatible with the robot controller i use.

technical specification of the robot:

- ABB IRB1400 M98
- ABB S4 / S4C Controler
- BaserWare 3.2 / RobotWare3.2

is there a special driver for the ABB S4 / S4C controller?

i would be grateful if someone could help me.

regards

martin
#7
This driver might be only compatible with the IRC5 controller.
I'll see with the team.
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#8
thanks for your quick answer. i'am waiting for your feedback.

regards,

martin
#9
Thanks for your communication!!
I want to ask some questions and hope you can reply! THANKS A LOT!
I am using the fanuc Robot in my research project, but I can't connect the robot with RoboDK. I saw some tips said that I should install the socket message function in my Fanuc robot, so I want to verify the truth of the information from you.
Thanks for your reply in advance~
#10
Hi,
As mentioned in the documentation, socket messaging and PC interface are required to establish a connection between a Fanuc controller and RoboDK.

https://robodk.com/doc/en/Robots-Fanuc.html#DriverFanuc

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


  




Users browsing this thread:
2 Guest(s)