Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RoboDK will not connect to KUKA KR6 robot
#11
Hi Andy,
I am working with a KUKA KR6 myself right now, there are one or two things that might help you.
In the config-file Jeremy posted above, there is a mistake. The variable is called
REAL COM_ROUNDM=0. Your config seams to content REAL COM RONDM=0.
Second thing is, as far as I know, you do not need a MainCom.src file. I have read about that file somewhere, probably the same source you got it from, but I am not using it either.
If you have defined the new variables correctly, the RoboDKsync.src is not crossed out. I also had trouble with that and fixed it by fixing the config file. What the manual does not say is, that you have to run the RoboDKsync.src program in 'automatic' mode on your robot controller.
Since you are using a KRC4 controller, I am having doubts that you chose the right config file. It should be in the hidden 'system' folder inside the R1 directory. The right config file contains a lot more data and has a specific section at the end which is labeled something like 'custom user variables'.
Maybe this leads you to the solution. Sorry for the bad structure, I would be more precise, but I am not at work right now.
Let me know if you are making progress, I get back to it next week.
Best regards
David
#12
Hi DavidG,

Wow, I can't believe that I didn't see that little typo from Andy's config file...
Thanks a lot for pointing that out.

Andy,
Correct that little mistake first.
Second, like DavidG said and like I said before, you are not supposed to create a new config file, you need to modify the existing one from your controller. As DavidG pointed out, there should be other variable already in that file.

Have a good day.
Jeremy
#13
I have a similar issue with the same robot.

Every time I reboot my modified $config.dat is overwritten by the original. Is there a way to prevent this from happening? Note I reboot without "reload files" checked.
#14
Hi, then try rebooting with reloading files, that should solve the problem.
Best regards
David
#15
Tried that. Same result.

edit: fixed it. I was in the wrong folder. Thank you DavidG you were right.
#16
Hello everyone!

I know this thread is from some months ago, but I am having some problems regarding online connection between Kuka robot (KRC4 controller) and robodk and it seems my problem resembles the one being discussed here.
I can make online connection between controller and robodk and I actually can 'get position' of the robot in robodk and it is consistent with position of real robot.
However, I can't use option 'move joints'. When I move robot to certain position (in robodk) and then hit 'move joints' nothing happens and message 'working' is displayed.
I believe this has something to do with 'RoboDKsync35' because I can't make it run on kuka controller HMI. When I select it it is displayed 'No object available' and so I can't even make it start.
Do you have a clue on what the problem may be?
#17
Hi Joaos,

Did you declare the global variables as explained in the following link?
https://robodk.com/doc/en/Robots-KUKA.html#DriverKUKA

You need to run the program RoboDKsync35.src to be able to move the robot from RoboDK.

Albert
#18
Hi,

Yes, I declared.
Here it is what's inside my $config.dat file:

"&ACCESS RV
&PARAM DISKPATH =
&REL 5
DEFDAT $CONFIG

INT COM_ACTION=0
INT COM_ACTCNT=0
REAL COM_ROUNDM=0.0
REAL COM_VALUE1=0.0
REAL COM_VALUE2=0.0
REAL COM_VALUE3=0.0
REAL COM_VALUE4=0.0
DECL E6AXIS COM_E6AXIS
DECL POS COM_POS
DECL FRAME COM_FRAME

ENDDAT"

I edited this information in the $config.dat file located in C:\KRC\ROBOTER\KRC\STEU. I managed it directly in robot controller pad by minimizing HMI and navigating in windows.
Sohuld I have edited another $config.dat file, located in another place in the controller, or is this the right file to be edited?
  




Users browsing this thread:
1 Guest(s)