Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RoboDK will not connect to KUKA KR6 robot
Hi Andy,
I am working with a KUKA KR6 myself right now, there are one or two things that might help you.
In the config-file Jeremy posted above, there is a mistake. The variable is called
REAL COM_ROUNDM=0. Your config seams to content REAL COM RONDM=0.
Second thing is, as far as I know, you do not need a MainCom.src file. I have read about that file somewhere, probably the same source you got it from, but I am not using it either.
If you have defined the new variables correctly, the RoboDKsync.src is not crossed out. I also had trouble with that and fixed it by fixing the config file. What the manual does not say is, that you have to run the RoboDKsync.src program in 'automatic' mode on your robot controller.
Since you are using a KRC4 controller, I am having doubts that you chose the right config file. It should be in the hidden 'system' folder inside the R1 directory. The right config file contains a lot more data and has a specific section at the end which is labeled something like 'custom user variables'.
Maybe this leads you to the solution. Sorry for the bad structure, I would be more precise, but I am not at work right now.
Let me know if you are making progress, I get back to it next week.
Best regards
Hi DavidG,

Wow, I can't believe that I didn't see that little typo from Andy's config file...
Thanks a lot for pointing that out.

Correct that little mistake first.
Second, like DavidG said and like I said before, you are not supposed to create a new config file, you need to modify the existing one from your controller. As DavidG pointed out, there should be other variable already in that file.

Have a good day.
I have a similar issue with the same robot.

Every time I reboot my modified $config.dat is overwritten by the original. Is there a way to prevent this from happening? Note I reboot without "reload files" checked.
Hi, then try rebooting with reloading files, that should solve the problem.
Best regards
Tried that. Same result.

edit: fixed it. I was in the wrong folder. Thank you DavidG you were right.

Users browsing this thread:
1 Guest(s)