Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Robot calibration trouble
#1
Hi, 
   i have a Motoman MA 2010 robot. When I give  joint values to robot in roboDK, the positioning of robot is different in RoboDK compared to the real robot. I've tried tuning the parameters of the robot and also imported the ALL.prm file. But this didn't help. The pulse generated by the file is different compared to the pulse shown on the teach pendant.

The movement of the robot is different in real life compared to the simulation. Additionally, the teach pendant shows an error when I try to run a motoman cartesian & motoman cartesianonly code generated from post processor. It works fine when I select motoman postprocessor. 

What could be the problem here, Am I doing it wrong?  


kind regards,
Nikhil Kumar Maniyanthotil


Attached Files Thumbnail(s)
       
#2
Did you follow these steps to properly import the pulses/degree ratio on the robot?
https://robodk.com/doc/en/Robots-Motoman...omanPulses

If you can share your RDK project and the Motoman ALL.PRM file we can better help you.
#3
Yes, I followed the same steps shown in the documentation for importing the pulses.

link for ALL.PRM : https://drive.google.com/drive/folders/1...sp=sharing

kind regards,
Nikhil Kumar Maniyanthotil


Attached Files
.rdk   motoman_calibration.rdk (Size: 12.77 MB / Downloads: 20)
#4
I see that the pulses/degree were properly imported. However, the home position for joint 5 does not look correct in RoboDK, I think it is off by 90 deg.

I recommend you to move the robot to the home position (all axes at 0 deg) and send a picture. You may need to do a mastering of your robot.
#5
I believe the joint 2 (L) is off by 90 degree and also some of the joints are inverted. As per your request, I have taken pictures of the robot to home position(0 degrees) and later moved all the join values to +30/-30 degrees for better understanding. The pdf with pictures can be seen in the link below.

https://drive.google.com/file/d/1EjOvLeQ...sp=sharing

with regards,
Nikhil Kumar Maniyanthotil
#6
As you can see in the pictures, joint 2 is set to +90 deg for the home position. This is not normal for a Motoman robot, usually all axes should be zero for the same home position.

In any case, you can adjust it in the parameters section of your robot:
  1. Double click the robot
  2. Select Parameters
  3. Select Unlock advanced options
  4. Set Theta 2 to 180 deg (it is currently -90 deg)
You can also adjust the joint senses by selecting Joint senses in the parameters menu.
  




Users browsing this thread:
1 Guest(s)