Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Robot port Fanuc R 30iB
#1
Hi guys,
I wonder, how to find the correct robot port for connect to robot. Where I need to look for this, on robot controler or on the PC? I tried to connect with standard 2000 port what it doesn't work, but I used the roboguide before on this computer and the connection was fine.

PS. Fanuc R-30iB controller. 

Best regards,
Piotr
#2
Hi Piotr,

Did you look at this part of the documentation:
https://robodk.com/doc/en/Robots-Fanuc.html#DriverFanuc

It seems like you need to set it on the controller­.

Also, make sure you have all the required options on the robot controller side. Fanuc can be tricky in that regard.

Have a great day.
Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#3
Thanks for reply.
I have a second question? Respecting to what you say, I need to instal and configure the drivers on the robot first, then try to connect? I was thinking that it was necessary only when I want to move robot by RoboDK not for loading programs. I want to use that for drip feeding which is executed by python script.

Have a great day,
Piotr
#4
Can you explain me and help with setup that connection? I will really appreciate.

Best regards,
Piotr
#5
Hi Piotr,

Oh, OK.
You are right, I miss understood.

Did you try connecting just with FileZilla?
Have you enabled FTP on the controller side?
https://robodk.com/doc/en/Robots-Fanuc.html#FTP-Fanuc

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#6
No, I didn't try connection with FilleZilla but I have connection with WinSCP. It's seems to work pretty good but I can't found any information about communication port with robot. I know that default port is 2000 but it isn't work. I think I should check if it is correct port but I don't know where to check it. I know you're not Fanuc producent but if you have any advice where I can look up for this it would be very helpful.

Piotr
#7
Hi Piotr,

You should make sure FTP is enabled on your controller and you are not using the program you are trying to transfer. I recommend you to try the connection with FileZilla on port 21 (default port for FTP transfer).

The 2000 port is for the Fanuc socket communication.

Albert
#8
Also using a Fanuc here. 

I'm not sure, but I don't think you need to buy the User Socket Msg option (R648) from Fanuc if you only want to upload files on the controller via FTP. To verify.

After having setup the FTP server on the robot controller, make sure to add the IP address of your PC in the client list. I don't have any screenshot nearby, but it should be do-able in the same menu where you setup your server IP address for the Fanuc (menu > system > host-comm, or something like that).

Usually, whenever I have trouble with something Fanuc-related, I call their support and they give me answers.

JFCh
#9
Thanks guys for help. I found that these controller doesn't have User Socket Msg (R648) installed, maybe this is the point. I saw that Socket Msg option is in the controller, is that option will be enough? I know I'm a little bit snippy, so I'm really appreciate for your advice. I must get to know how it works because in future I want to use RoboDK to communicate robot to send program and control robot in real time to probing.

Best regards,
Piotr
#10
Does it work now Piotr?

JEremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


  




Users browsing this thread:
1 Guest(s)