Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Robot position does not reflect target position.

I keep getting errors randomly every other program. The problem does not appear or disappear by changing programs. The problem shows up and disappears randomly within the same program without any changes to options, targets, reference frames, TCP, Base, or anything else. 

Most recently, I generated a program using Fusion360'3 RoboDK plugin's auto setup. The program ran fine, but I wanted to add a command at the very end of the program (which took a long time since I am also experiencing a glitch where the play/pause control bar keeps disappearing). All I did was make a small linear movement straight in the Z+ direction, in order to lift off of the part. Then a few joint motions guiding the robot back to it's home position. The target placements were fine. I made sure to avoid any singularities, and stayed well within joint limits. I got no errors. But what happened was, when I would tell the robot to go back to those targets, the robot would shoot out in an extreme direction and contort itself, positioning the TCP thousands of millimeters away from the set target. I could still see where the freshly positioned target is, and it is where it is supposed to be. But the robot will not go there, even though I used the robot's position to set the target.

It's like some sort of reference data freaks out for a bit, and the software forgets where the tcp, the target, or something is. But it still displays the target location graphically.

I will post screenshots if it happens again.
Hi Peter,

Are you using MoveJ on Cartesian Targets?
If you find a way to reproduce, feel free to attach your station.
Please read the Forum Guidelines before posting!
Find useful information about RoboDK by visiting our Online Documentation.
I had been using moveL and MoveJ on Cartesian targets. The result worked for the targets I had placed. Then after adding an additional target at the end, its almost like it corrupted the previously added targets (MoveL and MoveJ generated). The imported CAM path was fine though. Just the targets I added. Then every target generated afterwards would be wildly off from the target position placed by the robot. When this glitch started happening, I could position the robot, click to place a target, then click the very same target that I am still on, and the robot wont even touch the target I just placed without moving the robot.
Can you try the following for MoveJ commands with Cartesian targets?
* Right-click Program -> Recalculate targets.
* If this doesn't work, move the robot to the Target, right-click->Teach current position.
Please read the Forum Guidelines before posting!
Find useful information about RoboDK by visiting our Online Documentation.
Manually moving the robot to the target then teaching position did not resolve it. Additionally, each time I told it to move to the target, it would change position slightly.
I believe I solved it though. Throughout the system tree on the left, it seemed that there were a few duplicate target points (e.g. Target 1, target 2, target 1, target 1, target 3). After eliminating all of the duplicates, it had a better time locating the proper location of the target points.

Thanks for your time.

Users browsing this thread:
1 Guest(s)