Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Run program's control bar disappeared
#1
Greetings,

My play/pause/status/etc. bar that shows at the bottom when you run a program keeps disappearing. Tried restarting. Shut down the PC and rebooted. Reinstalled 64bit download of RoboDK. Nothin'. I cant bring it back. It's disappeared before, and come back, but now it seems to just stay gone.
#2
Does starting RoboDK using "C:\RoboDK\RoboDK-Start-Defaults.bat" fixes the issue?
If so, you can run "C:\RoboDK\RoboDK-Set-Defaults.bat".
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our YouTube Channel.
#3
Opening RoboDK from "C:\RoboDK\RoboDK-Start-Defaults.bat" does not fix the issue.

In the photo, I am running a program, but the play bar is missing. It came back briefly in the normal .exe, before disappearing again. After loading from "C:\RoboDK\RoboDK-Start-Defaults.bat", there was no change. It is still missing.

Nothing I seem to do really triggers it. I cannot recreate the problem with any specific steps. Just, as I keep running ther program, sometimes it shows up for a few cycles, then disappears again.

And it does not matter if I change programs or run other programs. Doesn't matter if its an imported CAM file, an auto-set-up from Fusion360 via plugin, or a native program made from creating target points.
#4
I could not find said photo in your post, did you attach it?

Do you still see the status bar in RoboDK (bottom bar that prints messages)?
Running the program with Ctrl+R does not open the sequence bar, while double-clicking the program should.
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our YouTube Channel.
#5
I added the attachment again. Is it there now?

I did not even know ctrl+R ran the program. Lol. I have only ever double-clicked a program, or right clicked and clicked "run."

Sometimes I will see a message bar at the bottom even when the play bar is missing.


Attached Files Thumbnail(s)
   
#6
It still just randomly disappears. There seems to be no connection between any combination of settings or actions. It's just there for a while, until I notice it is not. Feels like I'm rolling the dice each time I run a simulation. Then at some point, it just disappears while in the same station and program. closing and restarting RoboDK does not seem to have an effect either.

*update*
Hold up. I just right-clicked the program, selected "re-order" and clicked "move to the bottom." Then the play bar appeared. The program was already at the bottom, so it did not move anywhere. But maybe this will work each time? It's a band-aid for now. But perhaps if I can replicate it like this, it could give some insight as to what the bug is?
#7
The simulation bar at the bottom may not appear when you have a program with subprograms that move other robots or mechanisms.

Can you send us your RDK project file? We can better investigate.
  




Users browsing this thread:
1 Guest(s)