Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sanding Program And Blend Radius
#1
I am currently doing a sanding application with a UR10i robot. I am concerned with the warnings in our log when running my scripts, "Issue with blends a MoveP waypoint were skipped" its saying that the blend radius is to large for the distance between the waypoints. I changed the RoboDK post to have a minimum radius of .006 so if the calculated radius is smaller than .006 then my post forces .006, i did this because at the time it was thought that having a larger blend radius would help with some of the movements being jerky, and the calculated blend radius was very small in some cases, like .001. So i tried to set my tolerance very high in my CAM system and brought it into RoboDK and the simulation is jerky, i don't know if i need to be concerned with that or not, the output file had larger blend radius so it may run fine at the robot. I also found a post on this forum where it was mentioned to change the minimum step distance in the Options / Program tab but how much is too high? I guess my question is if any of you have experience with sanding or polishing where your CAM system outputs alot of points but you don't what all of them in your script, do i force very high tolerances in my CAM system, do i filter them in RoboDK, do i force the post to output larger blend radius
#2
Cobots in general are not very good at handling points very close to one another.
And they are even worst at handling blending for those very closely packed set of points.

The rule of thumb for UR would be to have a blending of a maximum of 40% of the distance between the 2 points.
I would also try to avoid less than 1 mm between points and go more towards 5 mm if I can. The larger the better.

You are saying it's jerky in RoboDK? Can you share your station.

Jerkyness in RoboDK doesn't necessarily translate to jerkiness on the robot and vice versa. So I would like to take a look.

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#3
Thanks for the reply. I can share it, just a zip file you mean? So you told me that 5 is best but not less than 1. I commented out my forcing of 6 when it is less than that in my post and i got some that were output as 0 so i'm guessing that this will not run very well? and i'm getting some that are 1,2,3 and so on, should i force 5 if it is less than 5 like I'm doing now or should i try to come up with a way thru filtering and such to get the 5 + blend radiuses?
#4
You can just attach your .rdk file and any other files you think I could need to replicate your setup.

I was made aware of a potential issue with the blending function of our UR post this morning.
I will take both examples and look into it.

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#5
Here ya go Jeremy. Thanks for looking into this for me


Attached Files
.rdk   SAMPLE 670 FEW POINTS.rdk (Size: 6.53 MB / Downloads: 15)
.cls   71366_CUT_1_5_REV.cls (Size: 1.44 KB / Downloads: 10)
.cls   71366_CUT_1_REV.cls (Size: 5.37 KB / Downloads: 13)
.cls   71366_CUT_0_5_REV.cls (Size: 1.51 KB / Downloads: 11)
#6
Hi, 

If you want to have a smooth simulation, you need to activate the rounding in the Robot Machining Project under "Program Events". 

You should put at least 1 there. 
   

There should be a filter in the post-processor that insures the blending won't be more than 40% of the distance. 
If it's a recent enough version. 

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#7
Thanks Jeremy. Can you explain how the max and min steps works on the program tab of the options form? in my tests, it only seems to affect non-cutting moves plus i have two boxes that are listed as being Maximum step size (deg)

   

Sorry, just noticed one says Maximum arc size and the other is Maximum step, but i was still wondering about these settings thou if you can give me some insight
#8
First option -> MoveJ

Middle 3 -> MoveL

Last 3 -> MoveC
(I know it's not obvious at first look)

Just to be clear, this won't affect the distance between the points in the simulation environment, this is just a filter applied before the post-processing.
Do you see a difference in the output program?

Also, I applied a fix to the UR post last Friday. You should download the latest version of RDK. Be aware that posts of the same name in C:/RoboDK/Posts are overwritten when updating.

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#9
Jeremy, I only see a difference in the non-cutting moves of the apt file, RoboDK adds additional points to my approaches and departures but the actual points on the part remain the same. I did down load the new version of RoboDK and i have questions about the post. I named and modified the Universal post of yours so my post was not overridden but this means it wasn't changed either, I did a compare and it would appear that the MoveL and the Blend_radius_check functions are different in your new version, should i cut and paste those new functions in my post?
#10
So Jeremy, i'm having trouble with the Rounding feature you told me about. in the program events when rounding is turned on, RoboDK post outputs that rounding value in my program which is causing the robot to stop using the value of 1 for rounding, so I turned it off and i am still getting the output in the program. I need this to not be output, am i missing something, i even set all my setting back to default but i still get this


Attached Files Thumbnail(s)
       
  




Users browsing this thread:
1 Guest(s)