Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Stäubli Driver

I am facing the exact same problem within following thread: staubli tx40 comunication issues (
I can connect to the roboter, and also get the robot's position. When I move the robot with the controller, the movement is shown on the screen. 

But if I try to move the robot manually in roboDK, the robot doesn't move. Also if I try to use a program (for example the program, from Robotertreiber - RoboDK Dokumentation). The error is attached bellow. Even if I just program a simple Script with 3 Movements and then try to "Run on Robot" - nothing happens. Neither an error is shown.

I also can't open the driver manually. I'm getting another error, also attached bellow.

How can I get my robot moving?


Attached Files Image(s)
Hi Janis,

Are you using the latest version of RoboDK?

We improved the Stäubli driver recently. Can you try again with the latest version and let us know if you still have issues?
I recommend you to try connecting using the user interface first and show us the log if the connection fails.

Hi Albert

Yes, i am working with the latest Version of RoboDK. I am able to connect to the robot through the user interface, i'm also gettin the green bar and the connection seems to be OK. It is also possible to get the real robots position on RoboDK - even if i move my robot with the controller manually, the position ist being updated in RoboDK. But I can not get my robot to move through RoboDK. And i don't get any error. 

I'm still trying to find out, where the problem is.

Attached is a picture of the log. As you can see, RoboDK tries to send a command, but the roboter is not moving at all...

Attached Files Thumbnail(s)
I found it out!
For anyone who may be facing the same problem:
Stäubli has a file named /usr/configs/iomap.cfx (you have to create it, if it doesn't exist),
which includes settings about the remote-access and other stuff.

The Code has to look like this

<?xml version="1.0" encoding="utf-8">
<String name="enablePower" type="din" value="DE55... (link of input)">

The value of the string "enablePower" has to be the link to a physical address on the robotcontroller. If you are in the remote mode and a rising edge is detected on this physical address, the state of the arm power will toggle. Since the Stäubli Driver does not work with setting digital inputs (maybe in the future?), you have to set the value on this physical link with something other than RoboDK (maybe a button or a trigger attached to your robotercontroller).
This is great feedback. We'll add the option to customize this. @Phillip will get back to you with an update in the next few days.

Thank you

Nice find @JanisP
We had the same problem and solved in a similar way.

We created and placed the file in ”/usr/configs" using FileZilla
Host: robotIP/usr
Username: maintenance
PW: spec_cal

Edit the only not commented line in the file to select the input, in our example "usrIn0" and save it as ".cf".
Then we attached a button to the corresponding digital input. 
Example as shown in the image below:

After activating the motors we could finally move the robot using RoboDK.

Attached Files
.txt   iomap.txt (Size: 4.79 KB / Downloads: 375)
Hi @JanisP and @Qu4dri,

Thanks for the solution! by the way I have the same problem
I already tried the .cfx code but the problem is it seem I couldn't find the right I/O's address
I use TX2 60 and CS9 controller.

What controller do you use for your robot?
and please could you help me how to find correct I/O's

Thanks for your kindly help
I am also working with a Staubli robotic arm (TX2-90, CS9 controller); however I am not able to connect to the machine using FileZilla. I receive the following error message.

Any help?

Attached Files Thumbnail(s)

Users browsing this thread:
1 Guest(s)