Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Staubli CS8 connection issue
#1
Hi

I'm trying to connect directly to my CS8 controller (TX60L robot) but having difficulty. I can connect via the Staubli SRS software, so I'm pretty sure the comms are working correctly. I'm running Windows 10 Pro.

I get two errors:

'apistaubli - the application was unable to start correctly'  and/or a series of '.dll files are missing' messages.
 

I have reinstalled both Windows and RoboDK with no luck. Would I be better off using Linux perhaps?  Any ideas please?

Thanks

Jonathan
#2
Hi Jonathan,

We just fixed the Staubli driver with our latest version of RoboDK. The missing files are now included with our installer.

This driver is only available for Windows and it is not complete (it has some functionality missing such as setting the tool or linear movements).

Albert
#3
Hi Albert

Thank you - updating to the latest version has improved things, although I'm still unable to control the arm from within RoboDK. I can ping it, but cannot 'get positions' for example.

I've also found that generated programs will not always open on the CS8. Having started with some simple examples, it seems MoveJ and MoveL work ok, but anything that contains a MoveC will not open. I've tried the four VAL3 Post Processors. Am I missing something?

Thanks for your help,

Jonathan
#4
Hi Jonathan,

To retrieve the robot joints using the robot driver you may have to try with the following ports depending on your controller:
  • CS8 Controller: 851 (it could also be 852 853 854)  
  • CS9 Controller: 5653
What issues do you see when you use circular movements?

There's a workaround to convert circular movements to small linear movements by changing the following settings:
  • Select Tools-Options-Program
  • Set Minimum arc size to 1 mm
  • Set Maximum arc size to 0.25 mm

   

Albert
#5
Hi Albert

It seems that using any of the Staubli Post Processors for programs including circular moves, except for the 'Simplified' version, gives an error of some description (see attached).  I've tried changing the min/max arc sizes as you suggest, but I still get errors. Do you have an example that you know works that I could try perhaps? It's an RX60L running on a CS8.

Many thanks, Jonathan



           
#6
Hi Jonathan,
This feedback is great. I noticed that one variable of the Stäubli Inline Move post was not being declared. I recommend you to try again with this post processor (just place it in C:/RoboDK/Posts and regenerate your robot program).
Let me know if it works better or not.
Albert


Attached Files
.py   Staubli_VAL3_InlineMove.py (Size: 37.88 KB / Downloads: 36)
#7
Hi Albert

I've tried using the updated post-processor, but I still get an error once transferred to the CS8 (see attached).

I've also attached the .rdk file that I've used. It's fairly complex so I'll try with something simpler too.

Thanks,

Jonathan


   
.rdk   LogoDXF.rdk (Size: 603.72 KB / Downloads: 20)
#8
This issue is probably because you have some program calls that don't exist in the robot controller. Taking a look at your project you use the default program calls for controlling the spindle, change the tool and execute M codes. You can remove or modify these settings here:
  • Double click your project settings
  • Select Program Events
  • See atttached image.
   

I recommend you to go in the log section to get a more detailed error description.

You can also ignore any program calls that don't exist in the station by following these steps:
  • Select Tools-Options
  • Select the Program tab
  • Check SKip program calls that don't exist in the station
#9
Thanks Albert

I've tried your two suggestions, along with the updated post-processor, which now gives a different error (see attached). The good news - it now works as expected using the 'VAL Simplified' post-processor which is great. 

I'll keep trying different things, but as you might have guessed, I'm a beginner!  Thanks again.


   
#10
You should make sure you transfer all the files of a program to the robot controller.

You can use the FTP transfer (Right click a program and select Send Program to Robot). Make sure to provide the correct IP of the robot and the remote path (path on the controller). I recommend you to use FileZilla to explore the controller files and locate the path where you want to place the programs.
  




Users browsing this thread:
1 Guest(s)