Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Staubli TX40 robot comunication issues

i have problems to communicate with staubli tx40 with the cs8c controller, i can connect and receive the position of the robot but then i can't make it move. using the run on robot function the robot always stays still without giving any error.
i also tried to use "Send program to robot", but then when i try to start the program from the interface on the pendant it gives the following error:
Invalid application: check program parameters in call()
or spwan instructions

currently i'm working on windows 10 with robodk version relase date 2021-03-22

any advice?
I'm sorry we took so long to get back to you. Do you see the same issues if you update RoboDK to the latest version?

I recommend you to follow this procedure to get the correct port (Stäubli SOAP server):

Have you tried different post processors?
Can you provide us with the RDK file and the connection log?
Good morning, I tried updating roboDK to version v5.2.4.20742-Relase date 2021-06-06, but it didn't solve any problems.
I can always make a connection with the robot, and get the current position by clicking on get position. 
But when I try to make the robot move (either with move joints or run on robot) the robot stays still, and in the logs the message "Sending command..." appears without anything else happening.
at this point any other command I send to the robot (including get position and Disconnect) shows the same message, and the only way to disconnect is to click twice on disconnect or close RoboDK.
Regarding the function "send program to robot" with all post processors (including the one attached to the link you sent me) the program is sent to the robot, but when I try to open it from the tech pendant always returns the same error as in the attached photo.
with regard to the connection port instead I connected via filezilla to the robot and I searched the file /log/system.log, but in the folder /log I did not find that file, but I found the information in the file errors.log, with indicated the port 5653, but even with this information has not changed anything.

Attached Files Thumbnail(s)

.txt   log.txt (Size: 598 bytes / Downloads: 420)
.rdk   testTX40.rdk (Size: 303.98 KB / Downloads: 374)

Is there any updates about this issue?

Thanks in advance!

Users browsing this thread:
1 Guest(s)