Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Timeout using the driver for Mitubishi RV2-FR robot


I'm trying to run a program on the Mitsubishi RV-2FR robot, but the robot stops after performing a single move and prompts me with an error. The error message is attached below. I get the same error when I try to move the robot with the RobotPilot plugin. It does move the robot once, but then prompts with the same error. 
I'm using apimitsubishi drivers and a free license of RoboDK.
I am connecting to the robot via graphical interface and not python script.
Can you please help me with identifying the source of the issue?


Best regards,
Did you allow the robot to complete the movement?

What version of RoboDK are you using? If it is not recent, can you try with the latest version?
I'm currently using version 5.6.5. What do you mean by allowing the robot to complete the movement? Robot makes only first move (both in program and in pilot add-in) and then states in status "working" and throws an error.
Can you try with a movement that takes less than 4 seconds? I believe there is a hard coded timeout of 4 seconds to complete the movement that should be increased to unlimited.

Can you contact us through our contact form?

We can better investigate this issue:
I will contact you through the contact form.
I now realize, that i've probably have been connecting through the incorrect port. I was connecting through the port 10001 and I should've used the port 10000. Now that i'm trying to connect with the robot through the port 10000 i get a message that i cannot make a connection because the robot is actively refusing connection (WinError 10061). On the robot itself i'm running a simple program that should allow me to control the robot in real time (Mitsubishi's 'Mxt' command). I have checked the ip adresses on both pc and the robot. I am able to ping the robot. The timeout parameter is set to -1 which disables timeot. I have tried to connect to the robot like it says in the instruction regarding Robot Drivers, which is through commannd line and by running a robot drivers python program.
Any help would be much appreciated.

Best regards
We improved the Mitsubishi driver since the last time you brought up this issue. Can you try again with the latest version of RoboDK for Windows 64 bit?

You'll find the download here:

If it fails, can you send us an updated print screen of the connection log?
I have downloaded the newest version of RoboDK, but the results are still the same. I've noticed that the version of apimitsubishi driver was 2.3.1 before downloading the newest version and is still 2.3.1 after the update. The program itself is now 5.6.7.
Here's the log:
Translation from Polish:  [WinError 10061] No connection could be made because the target machine actively refused it.
The version number is the same but we should have increased it as we modified the monitoring thread. You should not get the socket error now.

You don't need to use the console mode to troubleshoot for now. It should connect the same way you were able to connect before. Can you trigger a new movement with the new version?

Are you able to connect to the robot? The main issue is probably that the robot is not reachable. Did you properly configure your local network? Can you ping the robot? Can you connect to the robot somehow? (FTP, Mitsubishi software or any other method)
Here's the configuration of both PC and the robot. Let me know if you need any other parameters to know if it's properly configured.  I am able to ping the robot. 
I can connect to the robod within RoboDK and i can get the robot position, but only when I connect on port 10001. Port 10000 is suppose to be dedicated to real time control which is what i want and ports 10001-10009 are dedicated to data-link. If i understand correctly RoboDK's function Run on robot is meant to control the robot in real time, so i need to connect through the dedicated port. Perhaps I'm missing some crucial parameters settings. I'd really appreciate any help regarding proper configuration required to start using Run on robot function. There's also some TCP/IP settings on the robot's teaching pendant (TB) which I'm not sure i know what they're used for. I've tried changing the IP in there, but it didn't seem to change anything. Couldn't find any information on it in the manual.

Users browsing this thread:
1 Guest(s)