Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Trouble running RDK on AWS EC2 AmazonLinux2

Hi, I'm trying to get RoboDK (RDK) running on a newly created AWS EC2 instance (EC2I) which runs AmazonLinux2 (AL2), not Ubuntu. I am doing this in the cloud because the way my organization's network security is configured prevents me from communicating with the UR-10 robot over the local network. BTW, I do have a USB license key but am not using it with this EC2I, assuming the 30-day trial should suffice while I try to set this up.

So far I have installed RDK using the desktop GUI by running "Install-RoboDK".
If I click the RoboDK icon on the desktop the RDK splash screen flashes for <1s then disappears with no errors and RDK does not run.

I have tried again by running sudo ./ and have attached the complete output below.
The last two lines indicate that a segmentation fault occurs right after closing the splash screen.

Other things to note:
- The EC2I does not have a GPU, OpenGL is supported in software rendering mode using the Mesa drivers.
- I connect to the EC2I's desktop environment from my laptop using NICE DCV which is AWS's remote desktop tool.
- I'm struggling to understand how to install OpenGL drivers or how to make them work properly. I already have mesa-libGL and glx-utils. When I run glxinfo I get:

Quote:name of display: :0
Error: couldn't find RGB GLX visual or fbconfig

which seems to indicate there is an issue with my OpenGL configuration.

I'm wondering if I'm running into these issues because I'm trying to run RDK on AL2 instead of Ubuntu or if it should work but I need to resolve some other issues first. I appreciate any insight you may have to share.

Here is the output from running sudo ./
QFactoryLoader::QFactoryLoader() checking directory path "/local/home/user/RoboDK/bin/plugins" ...
QFactoryLoader::QFactoryLoader() looking at "/local/home/user/RoboDK/bin/plugins/"
Found metadata in lib /local/home/user/RoboDK/bin/plugins/, metadata=
   "IID": "RoboDK.IAppRoboDK",
   "archreq": 0,
   "className": "AppLoader",
   "debug": false,
   "version": 330752

Got keys from plugin meta data ()

loaded library "/local/home/user/RoboDK/bin/plugins/"
List of LOADED plugins:
Done list of plugins
Statusbar:  "Loaded 1 plugins"
Reading preferred layout settings...
Closing splash window
./ line 6: 28123 Segmentation fault      ./RoboDK /DEBUG
Interesting, I don't think we ever tried to run on AL2.

Can you get RoboDK to run with the -NOUI command argument?
Please read the Forum Guidelines before posting!
Find useful information about RoboDK by visiting our Online Documentation.
I believe I have resolved this issue!

I just needed to run:

sudo yum install mesa-dri-drivers

Then reboot the system and now RoboDK loads up no problem! (so far...)
I hope someone finds this helpful!

Users browsing this thread:
1 Guest(s)