Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
UR 10e Post Process Joint Value Error
#1
Hello,

When I try to process my programs from to robodk to my ur10e the values for the joints are off by ~5deg each and I am wondering if that is an issue of the way that I'm going about downloading it or if there is something I can do to combat this. 

I have tried running UR_LoadControllerKinematics with a program from our robot that has worked in the past and get this error. (see img 1)

Would love some insight on these issues and thank you for your help!

I have also read about people being able to upload urp files to robo dk and that doesn't seem to work either. When I try to do that I get the same error.

I read a forum that said to make sure that the robot was correct which I did. I made a new station, uploaded the correct robot, and tried again to no avail. I also tried updating robodk and that also did not work.

Could it be something with URSim? 

Thanks for the help,

WS

attachment for previous post


Attached Files Image(s)
   
#2
Did you generate the URP file using your UR robot controller? (not RoboDK or URSim)

I recommend you to follow the steps outlined in this section:
https://robodk.com/doc/en/Robots-Univers...Kinematics

Or simply load the URP file in RoboDK.

If it still fails, can you provide us with the URP file you are trying to load?
#3
Yes,

I just read through the article you linked. I followed the steps and while it did help a little bit the robot was still off by about an inch.

Here is the urp file being used.


Attached Files
.urp   CompleteCleaning6.24.21.urp (Size: 101.43 KB / Downloads: 14)
  




Users browsing this thread:
1 Guest(s)