Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

UR doesn't recognize that program is running after sending program from robodk

I'm trying to query the program state of the UR after making a program and sending it to the robot. The program successfully runs on the robot, however when I query Dashboard Server for the program state, it says that there is not a program currently running. It does not recognize that RoboDK has started a program. This only occurs when creating the program from RoboDK. When I create and run a program from the teach pendent, Dashboard server recognizes that a program is playing. Is there a setting or instruction that I am missing to inform the UR controller that a program has been sent and is running? Also I have unable to locate the generated programs on the UR. What directory are they saved to when they are uploaded to the robot? Can I change the destination?
Hi wmiller339,

Are you using the "run on robot" option or the "send program to robot" one?
Do you see any difference when using one or the other?

No I have not seen a difference between any of the program generation options. I have tried both 'run on robot' and 'send program to robot' in the GUI. I have also tried the 'MakeProgram' method in the python API (using each of the script-execution-modes).

All options give the same result. While the robot is executing the program, I query Dashboard server using the 'programstate' command.

The respones is: 'STOPPED test.urp'   ('test.urp' is the last program I had edited through the teach pendant)
Do you have a URe robot? If so, did you enable remote mode?

Contrary to UR robots, the remote mode needs to be enabled for URe robots. We recently added this section in our documentation:
Hi Albert,

No they are using a standard UR robot.

That is correct. As Jeremy has said, I am using a standard CB3 UR5 robot. Do you have any ideas on how to fix the problem?

Users browsing this thread:
1 Guest(s)