Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
UR5 won't load program
Hi all,

For a university project, I am trying to get the UR5 to follow a path with an extruder nozzle. In the RoboDK software, a file generated using Slic3r has been inserted and the robot will follow the path, and even generates a robot program but neither the .urp or .script files will load on the teach pendant. Note that the extrusion isn't performed using the robot program but is controlled independantly to the robot following the path. The .urp file says that it cannot load and the .script freezes the pendant, it was left for more than 10 minutes but nothing changed so it was powered down. Any help and insight would be greatly appreciated.

Many thanks
Hi Ruben,

What was you debugging process so far?
Did you try to load a simple program created manually in RoboDK? Just a few manually created targets?
Does that work?

Does it work with a smaller 3D printing program? Are you overloading the controller memory with the program you have right now?

Don't forget to take a look at this section of the documentation:

Have a great day.
Hi Jeremy,

Thank you for your reply. Sorry I forgot to mention, I was able to create a much smaller program with only a few points and was able to both load this onto the robot and successfully run the program. When looking at the program that wouldn't load there were a bunch of extrude commands which I have removed but I have yet to run this on the robot.

Hi ruben,

The Extrude commands require that you create a Extrude function in the robot controller which will be called by the main program when required.
You can remove them all of your program by opening your "3D printing project" -> "Program events" -> Remove the text in the "Set extruder feed".
That should solve that problem.

Now, if it's still problematic, try with a smaller print, the problem could be the size of the robot memory. It often happens with 3D printing or machining projects.
If this is the problem, you can use the "Run on robot" option. This way, RoboDK will stream the movement commands one by one. Note that you can lose the ability to use the rounding command though.

Hope it helps.
Hi Jeremy,

I'll try this as soon as I can, thank you for your suggestions. I ran into a new error that said:

'Caught unhandled exception!'
'Exception Caugt in Thread ProgressBarThread'
'java.lang.OutOfMemoryError: java heap space'

So I think that the direct 'Run on robot' option might need to be used.

Many thanks
Hi Ruben,

Can you send us a screenshot of the error message?
And a bit more information on when you faced it.

That would help us help you.
Hi Jeremy,

I believe when I came across the error message I was loading a .script in the teach pendant as the .urp wouldn't load. I have attached a couple pictures I could get of the message.


Since then I was able to modify the file that is output as per your previous suggestion but it still wouldn't load on the pendant, I waited for about 15 minutes so I am now looking into directly connecting my laptop to the robot to load the program that way.

Thanks for all the help.
Hi Ruben,

Can you provide the RDK project file?
The file is probably very large. In this case, I recommend you to use script files.


Apologies for the late reply, I have attached the RoboDK file and also tried to connect to the robot with an ethernet cable from my laptop but was unable to do so, neither of the IP addresses available when pinging were the same address listed on the teach pendant of the UR5 and when attempting to connect to the IP address listed on the teach pendant it was unable to.


.rdk   UR5 with test vase.rdk (Size: 26.64 MB / Downloads: 33)

Users browsing this thread:
1 Guest(s)